OpenArena Message Boards

OpenArena Contributions => Development => Topic started by: Danny on August 25, 2007, 05:55:43 am



Title: [BUG] 0.7.1 Patch (KAOS2) - HUNK_ALLOCATETEMPMEMORY: FAILED ON 16777224
Post by: Danny on August 25, 2007, 05:55:43 am
The new patch causes an error to be thrown up after the KAOS2 loading screen.

HUNK_ALLOCATETEMPMEMORY: FAILED ON 16777224

This doesn't occur without the 0.7.1 patch and I have also tried redownloading from a different mirror, so it's not a corrupt file.

At a quick glance it seems this only happens on KAOS2. I have tried this in both single player, and skirmish.

Thanks,
Danny.
Kubuntu 7.04


Title: Re: [BUG] 0.7.1 Patch (KAOS2) - HUNK_ALLOCATETEMPMEMORY: FAILED ON 16777224
Post by: next_ghost on August 25, 2007, 06:51:46 am
Try increasing com_hunkmegs.


Title: Re: [BUG] 0.7.1 Patch (KAOS2) - HUNK_ALLOCATETEMPMEMORY: FAILED ON 16777224
Post by: Danny on August 25, 2007, 07:10:26 am
Changing from the default 64 to 128 worked.
Maybe the default should be changed?

Thanks


Title: Re: [BUG] 0.7.1 Patch (KAOS2) - HUNK_ALLOCATETEMPMEMORY: FAILED ON 16777224
Post by: w1zrd on August 25, 2007, 09:06:46 am
I haven't heard that increasing hunkMegs should be required for kaos2, and I haven't had the problems myself either. Do you get the same error when loading the map without bots? 64, or even 54, should be enough for Open Arena to run smoothly if you're not using any custom maps.


Title: Re: [BUG] 0.7.1 Patch (KAOS2) - HUNK_ALLOCATETEMPMEMORY: FAILED ON 16777224
Post by: next_ghost on August 25, 2007, 09:13:27 am
I can confirm that 0.7.1 KAOS2 works even with com_hunkmegs 56.


Title: Re: [BUG] 0.7.1 Patch (KAOS2) - HUNK_ALLOCATETEMPMEMORY: FAILED ON 16777224
Post by: sago007 on August 25, 2007, 03:46:03 pm
What about people with custom player models? Do they also use the hunkmegs? Weapons models etc.?

Can there be difference on different architectures?


Title: Re: [BUG] 0.7.1 Patch (KAOS2) - HUNK_ALLOCATETEMPMEMORY: FAILED ON 16777224
Post by: w1zrd on August 25, 2007, 03:54:20 pm
What about people with custom player models? Do they also use the hunkmegs? Weapons models etc.?

Can there be difference on different architectures?
Normally it would be 2 mb allocated/model, that could be a reason for the crashes if the system is low on memory.


Title: Re: [BUG] 0.7.1 Patch (KAOS2) - HUNK_ALLOCATETEMPMEMORY: FAILED ON 16777224
Post by: Danny on August 28, 2007, 07:31:18 am
I have no custom models, etc. This is a fresh install. I have 2GB of RAM.

I can confirm that simply executing the command "map kaos2" works fine with hunkmegs 64.

Also, this problem exists with czest1dm and dm4ish in single player mode, giving the same number after "FAILED ON"...

Thanks,
Danny.

EDIT: If I go into skirmish on FFA the problem still exists, unless I either remove Kyonshi or Grism or (Raid and Dark). OA_RPG3DM2 works with the default bots, but if I change them to the KAOS2 bots I get the same error message. KAOS2 works in team deathmatch mode with the default bots.