OpenArena Message Boards

OpenArena => Technical Snafus => Topic started by: vio on April 01, 2010, 08:46:02 PM

Title: 0.8.5 Instillation Problems
Post by: vio on April 01, 2010, 08:46:02 PM
Hey guys, whenever I attempt to play an 0.8.5 game(on say the Digichalk server for example...) I run into numerous issues. If I'm actually able to join a game, I get a "no ammo" display on the top of the screen and I'm unable to manually switch weapons. Other times I'll not even be able to join and I'll get "bad item index" error or weapons error or something to that effect. I've tried installing the 0.8.5 patch multiple times now. I'm doing as the instructions say to do and copying all the new files to my OA folder and overwriting the old files with them. Am I doing something wrong here? If anyone has an idea what the issue is here, please help me!  I'd love to start playing games in the proper 0.8.5 mode. Thanks in advanced.

I'm running Vista 32-bit if that helps.

Title: Re: 0.8.5 Instillation Problems
Post by: Cacatoes on April 02, 2010, 08:30:08 AM
Hi and welcome,

Where did you install the patch ?

Do you have some custom .pk3 in your baseoa directory (not the one of the installation directory, but the one which keeps your "documents and settings") ? If yes (it is very likely if you have "autodownload on"), you may move these .pk3 elsewhere, it could solve the problem.
If you identify which .pk3 is causing this please tell us, because many complained about your problem but we can't reproduce this bug easily and we still have no clear indications to say to people in order to solve it.

Title: Re: 0.8.5 Instillation Problems
Post by: HITMAN on April 02, 2010, 12:43:26 PM
Just to be sure, did you download the version 081 first? and then run the patch 085?

If so, then you will probably have to adjust your settings in Openarena under System and Game Options.

In the System setup, change your network to the type of connection you are using
In Game Options, Autodownload should be on. Alot of servers have custom maps and the only way to get it is if you have the setting ON. If you dont, you will get errors.

Hope this helps too.

Also to elaborate on Cacatoes post...

He wants to know if you have any files (.pk3's) that are malicious which could be your problem. Since you may not know which .pk3 file to look for, I would just delete the entire Openarena folder. If you do this, you will start from scratch. All settings will be deleted and if you downloaded any maps, they will be gone too but you will be able to get them back later.

Heres the step by step process to delete that folder.

First, show all your hidden folders.
Second, goto C:\document&settings\(username)\appdata\roaming.
Third, Delete the Openarena folder. Thats it.

Title: Re: 0.8.5 Instillation Problems
Post by: vio on April 02, 2010, 10:13:14 PM
Ok guys. To answer your questions, yes I had 081 already. I've had it for a couple months. And yes, I already had auto downloading on. I also had my connection set to DSL/Cable. Everything was fined tuned as I used that very helpful tutorial that was recently posted here on the forum to get everything set properly. So those weren't the issues. The problem was in fact with one of the pk3's or something 'else' in the appdata OA folder. I did like you said and just trashed it entirely. That seems to have fixed the problem. Everything looks good now. I have the new menu layouts and so far there haven't been any problems playing on 085 servers. I'll let you guys know if I run into any other problems.

Thanks a ton!

Title: Re: 0.8.5 Instillation Problems
Post by: Cacatoes on June 02, 2010, 08:09:04 AM
Just to confirm, when you connect to some unpure 0.8.5 server with an old QVM, you'll get "Out of ammo" messages, and you won't be able to change weapons.
The solution: delete the .pk3 which is responsible of this. You have to identify it.
(this one can cause this: )

Title: Re: 0.8.5 Instillation Problems
Post by: Logan on June 02, 2010, 07:20:38 PM
Digichalk 0.8.5 is an unpure server. I asked for this so players could use custom models if they wanted too.

I had no idea it would potentially be a factor in this problem, but I have never experienced it myself.