OpenArena Message Boards

OpenArena => Technical Snafus => Topic started by: hemite on March 10, 2012, 01:22:34 am



Title: Issues Running on Mac
Post by: hemite on March 10, 2012, 01:22:34 am
My sincerest apologies if this is the incorrect forum thread or whatnot, This is my first time posting.

*Anyway*

Two issues I wanted to ask about. Firstly, When downloading the .8.8 version I could not running it on my mac machine (snow leopard 10.6.8). To fix this I downloaded the .8.5 and copied the executable app over to the .8.8 folder. This seemed to fix the problem and I am not running the .8.8 version normally. Secondly, I am not able to use 3rd party maps with the game. If I drag them over to the baseoa folder they don't show up in my map selection screen. Any tips on how to fix this?
Thanks in advance and thanks for a great product anyway.


Title: Re: Issues Running on Mac
Post by: Tiny on March 10, 2012, 03:16:26 am
To run 0.8.8, you should add the folder you dled into the 0.8.5 folder in your applications folder :P That should be working normally, if not i don't see the problem, maybe you can explain a bit more?

And about the second point, the maps/configs and such are not placed in the baseoa folder in the Open Arena folder you got in the applications, you got to get into the library, then -> applications support, then -> Open arena, and there you'll find a baseoa folder with all your maps/configs, and that's where you have to put maps if you want them to show up ingame ;)


Title: Re: Issues Running on Mac
Post by: hemite on March 10, 2012, 03:39:15 am
So I tried putting it in my ~/Library/Application Support/openarena/baseoa/ and I still don't see the map. The map is q3dm6.pk3 so I assume it should work.


Title: Re: Issues Running on Mac
Post by: GrosBedo on March 10, 2012, 04:07:38 am
That's not normal, you should be able to place your additional packages either in lib/appsupport/... or directly in your installation folder as you did in the first way, in both ways you should see your map.

Please try with some other packages. Also, the pk3 should be directly dropped into baseoa, it should not be contained inside a subfolder (eg: no baseoa/q3dm6/q3dm6.pk3).

Also, some maps aren't shown in the menu (that depends on their configuration), but are still accessible to play, so just try to type /devmap q3dm6


Title: Re: Issues Running on Mac
Post by: hemite on March 10, 2012, 04:16:30 am
As of this moment, my q3dm6.pk3 is in my openarena/baseoa/ folder. This open arena folder contains the application I click to launch the game. q3dm6.pk3 is also in my ~/Library/Application Support/openarena/baseoa/

The map does not show up in the list and /devmap q3dm6 does not work. The message was that q3dm6.bsp was not found.


Title: Re: Issues Running on Mac
Post by: jackoverfull on March 10, 2012, 07:04:56 am
Regarding the first problem, that's a known problem, see here: http://openarena.ws/board/index.php?topic=4474.0

You can get a working 0.8.8 mac binary here: http://www.jackoverfull.com/tmp/OAMac088r28.zip

About the second issue, just tried with void4b1, you can place new maps (compressed in the usual .pk3 archives) either in the main baseoa folder or into /Users/youruser/Library/Application Support/OpenArena/baseoa.


Title: Re: Issues Running on Mac
Post by: GrosBedo on March 10, 2012, 08:52:54 am
You should then try with a few other pk3 to check if the problem maybe reside in your q3dm6.pk3 being corrupted.


Title: Re: Issues Running on Mac
Post by: hemite on March 10, 2012, 12:21:27 pm
You should then try with a few other pk3 to check if the problem maybe reside in your q3dm6.pk3 being corrupted.

Yes that seemed to exactly be the problem. I downloaded q3dm1.pk3 and put in my my baseoa folder which worked fine. I will try to get another version of q3dm6. Thanks everyone for the help. If anyone knows a map pack with all the original quake3 maps and where I can get it that would be fantastic.


Title: Re: Issues Running on Mac
Post by: GrosBedo on March 10, 2012, 02:15:02 pm
There's the dreamcast map pack, you can find it on all major maps repositories (such as lvlworld I think).


Title: Re: Issues Running on Mac
Post by: hemite on March 10, 2012, 02:27:59 pm
I got one called dc-mappack.pk3 but I don't think it loaded correctly. The maps don't show up on the list and and I'm not sure how to refer to them using /devmap because I don't know the names of the maps included in the mappack.


Title: Re: Issues Running on Mac
Post by: Gig on March 10, 2012, 06:07:54 pm
Just a side note: /devmap is the command to load a map in "developer" mode, with cheats enabled. The normal command to load a map is simply /map <mapname>. Using the autocomplete "tab" feature with it, you can see the list of all available maps in your machine.


Title: Re: Issues Running on Mac
Post by: GrosBedo on March 11, 2012, 04:57:57 am
Yes Gig is right, I advised /devmap only for testing purposes before, because I *think* devmap has less strict checking that /map, but now you should be using /map.

Hemite, please double check that you have placed the pk3 in the correct place, in the correct folder (it happens that users have unzipped several times the OA archive and so you get several OA installations).


Title: Re: Issues Running on Mac
Post by: Tiny on March 12, 2012, 02:14:04 pm
I got one called dc-mappack.pk3 but I don't think it loaded correctly. The maps don't show up on the list and and I'm not sure how to refer to them using /devmap because I don't know the names of the maps included in the mappack.

If a map/mappack didn't load completly, it should be a .tmp

Some maps don't show up in the list for me either, but if i got them in my baseoa folder wich is in the library, i can run them with /map"xxxx" , about dc, you can try pro-dcmap7, iirc it's in this pack ;)


Title: Re: Issues Running on Mac
Post by: lingenfr on April 06, 2012, 09:37:34 am
I am running on the latest patched version of OS X (Lion). Back to the original post. I previously ran 0.8.5 fine. When all of the servers started to throw errors about he new version, I downloaded the patch. No joy. I deleted the 0.8.5 folder and downloaded the full 0.8.8 version. In the folder, there seem to be two executables, Openarena and on with r28 suffix. Neither will run. I get the bouncing OA icon in the task bar which continues until I click on it. I reinstalled OpenAL. Can't figure it out. What I am doing wrong?  Thanks.


Title: Re: Issues Running on Mac
Post by: hemite on April 06, 2012, 11:07:21 am
Try downloading both 0.8.8 and 0.8.5. Then move only the "app" from 0.8.5 to 0.8.8 (overwriting the 08.8 app). That's what I did to get mine to work but I am running snow leopard not lion.


Title: Re: Issues Running on Mac
Post by: lingenfr on April 06, 2012, 01:36:46 pm
I would, but it doesn't seem to available anywhere. The deprecated patch is all that is there and it does not include the app file.


Title: Re: Issues Running on Mac
Post by: lingenfr on April 06, 2012, 04:20:24 pm
I used the 0.8.1 app and that worked. As long as your were able to solve that, my world will be complete if you could tell me how to use the function keys in OA on a Mac. I have tried a lot of combinations with no joy. Thanks.


Title: Re: Issues Running on Mac
Post by: hemite on April 07, 2012, 01:01:43 am
What specifically do you need to use the function keys for while playing oa?


Title: Re: Issues Running on Mac
Post by: Gig on April 07, 2012, 02:12:42 am
AFAIK, 088 full package MAC executables need to be tweaked (by using CHMOD command, probably) to be "runnable" (this due to the packaging done with Windows, that messed up Mac permissions). If you don't know how to CHMOD (maybe it's in some thread around here), you should anyway be able use 0.8.8 PATCH download instead, to have working Mac binaries.


Title: Re: Issues Running on Mac
Post by: lingenfr on April 07, 2012, 07:06:55 am
I know chmod +x, but since copying the app worked and I doubt it has changed, I am not going to fool with it. Still would like some help on how to use the function keys in OA (and UT2004, etc, etc). Thanks.


Title: Re: Issues Running on Mac
Post by: Gig on April 07, 2012, 08:15:29 am
The engine has been updated from 0.8.1 to 0.8.8, with some new features (e.g. optional glsl and "cascaded" bloom effects - see (DO NOT LINK) h t t p s : / / openarena . wikia . com/wiki/Manual%2FGraphic_options) and fixes (you can read the 0.8.x binaries thread here: http://openarena.ws/board/index.php?topic=1933.0), anyway you can still play with old binaries, no problem.

For Mac issues, try to send a PM to Jackoverfull (who posted a message here on 10 march, I see), asking him to come here.


Title: Re: Issues Running on Mac
Post by: Tiny on April 08, 2012, 01:44:34 am
There are some problems running the full 088 dl on Mac.

If you wanna run it, just get 085 first, and then add the 088 pk3 ( that you get in the dl ) in your baseoa folder located in the 085 applications folder, and then it'll work ;)


Title: Re: Issues Running on Mac
Post by: lingenfr on April 08, 2012, 05:28:24 pm
I assume the "cascaded" bloom effect would insure that my blood and guts fly in a smoother pattern kind of like a champagne fountain. As everything seems to be working, I'm not going to fool with it anymore. Hopefully if they do a hotfix it will fix the problem with the 0.8.8 app file. Thanks for the help everyone. Still would like to know how to make the function keys work (kind of helps with F1/2 votes).


Title: Re: Issues Running on Mac
Post by: hemite on April 08, 2012, 06:42:31 pm
Oh, that's what you needed the function keys for. I just use fn+f1 or fn+f2 for voting.


Title: Re: Issues Running on Mac
Post by: lingenfr on April 08, 2012, 08:07:58 pm
Was sure I'd tried that, but it seems to work. Thanks. Hopefully it will also work in UT2004.


Title: Re: Issues Running on Mac
Post by: Gig on April 09, 2012, 03:24:10 am
I just added DO NOT LINK[/b]) h t t p s : / / openarena . wikia . com/wiki/FAQ#Function_keys_.28F1-F12.29_don.27t_work_as_expected]a section to the FAQ page (http://([b). Is that ok?


Title: Re: Issues Running on Mac
Post by: hemite on April 09, 2012, 04:56:55 pm
Looks good Gig.


Title: Re: Issues Running on Mac
Post by: Gig on April 10, 2012, 03:39:13 pm
About the executables problems, I added DO NOT LINK[/b]) h t t p s : / / openarena . wikia . com/index.php?title=Download_mirrors&action=historysubmit&diff=12382&oldid=11996]this (http://([b) to the "Download mirrors" wiki page. Please fix it if needed, then I may write it also in some other pages...