Pages: [1] 2 3 ... 5
  Print  
Author Topic: we got a serious problem here  (Read 66808 times)
aantipop
Half-Nub


Cakes 3
Posts: 66


« on: June 12, 2008, 01:12:29 AM »

the last few days i noticed that the openarena servers are not very crowded anymore. i have a 0.7.1 installed and 0.7.7 but i cant find a good ctf server any longer. people are split in 3 versions which are all not compatible. i guess some long-time openarena players already left because of that situation. i miss the 0.7.1 days with a lot of regular, strong players around the servers..


so what can be done to unify the OA community again ?


-  server admins need to get informed about the situation and the update to 0.7.7
-  force protocol 69 on the master-server OR go back to 68 and have a "outtdated version" message,not the invalid folder one
-  most important: provide a binary with the holy "old" input system for 0.7.7 (which can already be found at http://rainbow.furver.se/)



Logged
<< ME >>
i claim to be leilol and i think every forum is a public and free speech venue
Member


Cakes -2
Posts: 230


0Wn ME iF yOu Can!!!


« Reply #1 on: June 12, 2008, 08:53:34 AM »

*sigh*
Ive been telling you all the same thing over and over again...!
If you want to get into a good CTF server, go to Nemesis server though its running 0.7.1 and I dont know if thats ok for you.


-Server admins (most of them I would say 98%) know about the new release, and I personally had asked about changing to 0.7.7 in each server and most of them dont want to, 'cause IE: "when I tried 0.7.7 the server crashed over and over", "the mouse in 0.7.7 is weird", "the players of this server prefer 0.7.1"...

-Heh... You know we must keep dreaming... dont think that will happen Sad

-The last time I tried to put a link and specify something about the Mighty RN my post was deleted Sad my only intention was that, to let know everyone the awesome work they are doing to avoid losing more ppl, to give a hand with some troubles ppl post here and sometimes the replies are just OFF-TOPIC.
Logged

"uh.. FREE SPEECH?? does it make any sense to you??
Deleting posts and locking topics is just the same as banning"
fufinha
stop making alt accounts and self-termination
Member


Cakes 7
Posts: 584


retired


« Reply #2 on: June 12, 2008, 10:35:06 AM »

aantipop.

0.7.1 is now a thing of the past for a developer.

It is still an end product and should be treated as such. By suggesting we must do something, such as upgrade, whatever, IMO only means that you couldnt care less about what you currently have.  The roadmap should be exactly that. You move along and who knows where it leads to. But you do not turn back and destroy what you leave behind.

Remember, many people might be  completely unaware of all the politics and what not, why should we go a unsettle people because we feel it's for the best, I am certainly not in any position to do that, and neither is anyone here. We may not share the same opinions, but that is not a bad thing.

If 071 isnt good enough enough for you then you have the choice to go where you want. You know, I can still go back and play the first server that all the noobs used to go on. It's so funny because the machine must be a piece of shit, but you can stumble accross people who are just the same as you, people who were just the same as you at the time Smiley Funny thing is, that server has never changed, not a single bit for god knows how many years.  It's a part of history now. Who knows, by being lazy I may be a visitors attraction in the future, the server maybe antique. When the time comes where you can launch the game, look at the server list and recognise the identities of servers, that is what makes a community.  The dev team can say all they want, but wether they like it or not, I will always be that stubborn cow. I also hope they will look back and laugh, cos sure fuck I will - I am not doing any harm nor  am I here on a mission and take things that seriouslly, I'm one of the lucky ones. Even my friends have fled to 0.7.7.. they can still come back and visit and get the same ass kicking as before, assuming I'm not already evicted.  Smiley 
Logged
Mr. Oho
Half-Nub


Cakes 0
Posts: 55

I will press the button!


« Reply #3 on: June 12, 2008, 05:13:27 PM »

the last few days i noticed that the openarena servers are not very crowded anymore. i have a 0.7.1 installed and 0.7.7 but i cant find a good ctf server any longer. people are split in 3 versions which are all not compatible. i guess some long-time openarena players already left because of that situation. i miss the 0.7.1 days with a lot of regular, strong players around the servers..

Yeah i totaly agree... Splitting of playerbase is possibly the worst thing that can happen to OA :/ The main (only?) problem of  0.7.7 seems to be the input stuff but i guess the dev team is allready investigating/wighting options on that. Cant say im realy affected by it but possibly just because Quake3 isnt my "Homegame" and controls feel weird anyways Tongue.

From the serverside i didnt have any problem at all. Ok 0.7.6 had that weird sticking together thing but going back to the old engine took about 2 minutes... big deal. So admins if your on linux and are having problems you might want to check your config Wink

But heres 2 suggestions (SUGGESTIONS - i realy hate it when people treat producers of free stuff as their own fulltime dev team...):

- Change pk3 naming. Add an incementing number or US-style date to the names so files wont have to be overwritten. This way people could maybe even just download update pk3s from servers and pure decides what pk3s get referenced.

- Do not use latest builds of IOQuake3. Use a stable and proven version for releases but supply newer build for those who feel adventurous. This way engines can get some testing before everyone gets to use it.
 
Logged
fufinha
stop making alt accounts and self-termination
Member


Cakes 7
Posts: 584


retired


« Reply #4 on: June 13, 2008, 04:08:14 AM »

Yeah, that is a great suggestion. Wouldn't that enable players to use a common tool that can switch versions to whatever you want, if one was ever to be developed?

If OA continues to develop for a long time then maybe one day I will replace my 5 year old piece of crap and check out all the new stuff. I did it to use defrag on Q3 but 1.32 is so crap, I play on 1.16 from 2000.

It's clear that the developers here are now openly critical of their own product, which I find odd. Yes I know about crappy bits but they dont affect me at all. What about gamehosters and people running an OA version as a project? I know a few players who know the game hosters pretty well and they seem to be influential and be able to attract more players. I don't care about game hosting but wouldn't say no if there were enough people to have a game of TDM. But many people dont even bother going to any forum, never mind the OA forum. This is only a small part of OA, many people who have downloaded OA could be from just word of mouth. I just thought this forum was mainly for development anyway, so I took a look at the release notes and seen the wiki page was still listed and still contains the links for 0.7.0.

I laughed when I seen a post of someone posting an announcement that there were actually 10 REAL people on one server Smiley I see that RN have made a sacrifice to go and help assist with the support for 0.7.7, even though they are unhappy with some future changes. I think that counts for alot, so I would like to see an end of all this 'lazy admin' crap and laughing at people using 0.7.0. I know individuals are entitled to have opinion but does sago share the same opinion? As previously noted, he contributed largely to 0.7.7. Will 0.7.7 be laughed at when the next release comes out? Can't there be a clear distinction that a message is from a user with a name like oa-admin or devteam. I don't even know who the development team are, I know of sago and jackoverfull but it's not very clear. fromhell doesnt even accept pm's. Isn't that anti-development? People who write you bug messages and maybe info of potential cheats or even offer to help.. these messages are only rejected once sent. The may not be appropriate for posting public.
Logged
fufinha
stop making alt accounts and self-termination
Member


Cakes 7
Posts: 584


retired


« Reply #5 on: June 13, 2008, 04:27:36 AM »

(DO NOT LINK) h t t p s : / / openarena . wikia . com/wiki/Image:SimpleCover.png

hahaha.. that should be under the heading 'humour' Smiley The one we want to forget.

This should be on the main OA front page I think : (DO NOT LINK) h t t p s : / / openarena . wikia . com/wiki/Changes

I looked for others but just ended up at loads of technical crap. However, I did notice this Smiley http://irc.wikia.com/ oa - isnt there, i can do this. I offer you my time to contribute and I can do this. I will give people great advice Cheesy
Logged
kick52
Member


Cakes -1
Posts: 229


« Reply #6 on: June 13, 2008, 06:20:06 AM »

I agree with really fucking the old protocols.
Just letting everyone play old versions is unacceptable and backwards to the development of the project.
Logged
aantipop
Half-Nub


Cakes 3
Posts: 66


« Reply #7 on: June 13, 2008, 09:42:59 AM »

the normal evolution would be that the people upgrade because the newer version is better, though
Logged
<< ME >>
i claim to be leilol and i think every forum is a public and free speech venue
Member


Cakes -2
Posts: 230


0Wn ME iF yOu Can!!!


« Reply #8 on: June 13, 2008, 10:26:36 AM »

the normal evolution would be that the people upgrade because the newer version is better, though

But ITS NOT!
Logged

"uh.. FREE SPEECH?? does it make any sense to you??
Deleting posts and locking topics is just the same as banning"
kick52
Member


Cakes -1
Posts: 229


« Reply #9 on: June 13, 2008, 11:23:17 AM »

the normal evolution would be that the people upgrade because the newer version is better, though

But ITS NOT!

It is better.. but not much better if you do the same game types etc.
What we need to do is force all players to update.
FFS, remove the old protocol! Or make all server names etc "UPGRADE TO 0.77"
This is a (probably) simple fix, why are we not doing this?
Logged
aantipop
Half-Nub


Cakes 3
Posts: 66


« Reply #10 on: June 13, 2008, 12:50:48 PM »

maybe because it would not be correct in a political way ? or against players freedom  ?!
Logged
rashdawg
Half-Nub


Cakes 5
Posts: 52



« Reply #11 on: June 13, 2008, 05:11:41 PM »

Ok I am not really for or against 0.7.7.  I am just shocked in the way people are acting as if the players do not matter.  I mean really isnt the point of a game to have players to play it.  I dont think it matters if players are playing the old version.  The way the players of 0.7.1 are being treated may just make them leave OA altogether.  There is so much hostility.  Why cant we get those 0.7.1 players to give feedback what they want in 0.8.0.  I am just saying to think about the players and not be so selfishly bullish that 0.7.7 is so much better than 0.7.1.
Logged

TheWorstOAPlayer aka RashDawg
Logan
Member


Cakes 2
Posts: 367


I'm one of those Canadians you've heard about


« Reply #12 on: June 14, 2008, 12:21:50 AM »


FFS, remove the old protocol! Or make all server names etc "UPGRADE TO 0.77"
This is a (probably) simple fix, why are we not doing this?

I agree, it might be a good idea to make things clearer for the not so wise players to understand whats going on.
Logged

*Logan*




Let Me Kill You In Open Arena--> Digichalk 0.8.5
Let Me Kill You In Quake Live--> Logan26
fufinha
stop making alt accounts and self-termination
Member


Cakes 7
Posts: 584


retired


« Reply #13 on: June 14, 2008, 05:31:16 AM »

edit
« Last Edit: June 14, 2008, 05:55:51 AM by missbehaving » Logged
kick52
Member


Cakes -1
Posts: 229


« Reply #14 on: June 15, 2008, 07:51:54 AM »

Ok I am not really for or against 0.7.7.  I am just shocked in the way people are acting as if the players do not matter.  I mean really isnt the point of a game to have players to play it.  I dont think it matters if players are playing the old version.  The way the players of 0.7.1 are being treated may just make them leave OA altogether.  There is so much hostility.  Why cant we get those 0.7.1 players to give feedback what they want in 0.8.0.  I am just saying to think about the players and not be so selfishly bullish that 0.7.7 is so much better than 0.7.1.

The 0.7.1 players aren't upgrading because they do NOT know about 0.7.7 at all!
The 0.7.1 players haven't played 0.7.7/6 and they haven't said they haven't liked it. This is because there is no community-development communication at all.
Logged
GrosBedo
Member


Cakes 20
Posts: 710


« Reply #15 on: June 15, 2008, 09:54:45 AM »

The 0.7.1 players aren't upgrading because they do NOT know about 0.7.7 at all!
The 0.7.1 players haven't played 0.7.7/6 and they haven't said they haven't liked it. This is because there is no community-development communication at all.

Why people just can't understand they don't know what others can think ? Listen to what is being said. There are many people knowing the new version is out, but prefer to play the old one. Some others like me keep and play both. There is a reason why we are in this situation, it never happened in the past, and the community wasn't smaller. We should try to understand and correct the cause instead of whining after the effect.
Logged
<< ME >>
i claim to be leilol and i think every forum is a public and free speech venue
Member


Cakes -2
Posts: 230


0Wn ME iF yOu Can!!!


« Reply #16 on: June 15, 2008, 11:12:23 AM »

Ok I am not really for or against 0.7.7.  I am just shocked in the way people are acting as if the players do not matter.  I mean really isnt the point of a game to have players to play it.  I dont think it matters if players are playing the old version.  The way the players of 0.7.1 are being treated may just make them leave OA altogether.  There is so much hostility.  Why cant we get those 0.7.1 players to give feedback what they want in 0.8.0.  I am just saying to think about the players and not be so selfishly bullish that 0.7.7 is so much better than 0.7.1.

The 0.7.1 players aren't upgrading because they do NOT know about 0.7.7 at all!
The 0.7.1 players haven't played 0.7.7/6 and they haven't said they haven't liked it. This is because there is no community-development communication at all.

Its really a shame from you to say that...! If ppl say they dont like 0.7.7/6 its because they've already tried it and played it and so on...
You are saying ppl dont like/play 0.7.6/7 even without played it and its only 'cause of what they heard..!

Thats stupid. How can you say that!? Jeez!!
Logged

"uh.. FREE SPEECH?? does it make any sense to you??
Deleting posts and locking topics is just the same as banning"
fromhell
Administrator
GET A LIFE!
**********

Cakes 35
Posts: 14519



WWW
« Reply #17 on: June 15, 2008, 11:13:59 AM »

unaware != doesn't like

0.7.0 had a digg article. 0.7.6 didn't.

0.8.0 will get a digg article.
Logged

asking when OA3 will be done won't get OA3 done.
Progress of OA3 currently occurs behind closed doors alone

I do not provide technical support either.

new code development on github
kick52
Member


Cakes -1
Posts: 229


« Reply #18 on: June 15, 2008, 11:57:39 AM »

Sure, you two/three may not like 0.7.7 (even though there is no fucking reason not to!), but this doesn't mean that EVERY 0.7.1/0 player has this same view.
You people are an active part of the community, so you know about the new releases etc. from the main page and forums.
Other people only play the game, and don't visit the website etc, so how else would they know about the new release?

It's highly realistic that people just don't know about the game. Also, can you REALLY see a typical Quake player being pissed off and reverting to an old version over new features after waiting for the download and install? I cannot.
Logged
Mr. Oho
Half-Nub


Cakes 0
Posts: 55

I will press the button!


« Reply #19 on: June 15, 2008, 07:25:57 PM »

FFS, remove the old protocol! Or make all server names etc "UPGRADE TO 0.77"
This is a (probably) simple fix, why are we not doing this?

As much as i like simple wouldnt it be a better idea to integrate some kind of update ticker into future releases? No, it wont work now but i think it would provide a nicer way of telling people about updates.
Logged
pulchr
Member


Cakes 34
Posts: 626



WWW
« Reply #20 on: June 16, 2008, 12:15:47 AM »

Also, can you REALLY see a typical Quake player being pissed off and reverting to an old version over new features after waiting for the download and install? I cannot.

Yes, this is HIGHLY REALISTIC as the game does not FEEL like it used to. the movement has CHANGED from what quake 3 has always felt like. this does not apply to all players as the input seem to vary for all players. however, it occurs to MANY players. have you not seen threads and answers from players criticizing the new SDL input?
Logged
kit89
Member


Cakes 6
Posts: 636


Shoot him..


« Reply #21 on: June 16, 2008, 03:53:48 AM »

As far as I'm concerned 0.7.0 was an official release, with 0.7.1(stable) fixing bugs that were not known at development.

As for 0.7.6 & 0.7.7(beta), they are test beds, In what you could say the bleeding edge of this game & with that comes problems.

Instead of trying to force players to play 0.7.7 over 0.7.1, ask them to send bug reports in. The developers can't fix problems it's unaware of & the last time I checked most of the developers for OA are running Linux/Mac, while the main user base is Windows & it's the Windows version that is having problems.

So come on Players of OpenArena, send in your Bug Reports!
Logged
fufinha
stop making alt accounts and self-termination
Member


Cakes 7
Posts: 584


retired


« Reply #22 on: June 16, 2008, 04:42:37 AM »

oK lets get back to the insanity.

FAO kick/aantipoop @ similar minded ppl : Your issue is over a lack of servers / players on 0.7.7. You don't really care about OA nor do you care about anything other than yourselves.  I use Windows XP and there is noone forcing me or suggesting to these ridiculous bull dozer solutions to upgrade to vista so that things can be the way you want it. Can you imagine if the developer of this forum software were to come here and give us all this crap that the forum has been updated and much better SO UPDATE NOW ITS EVOLUTION. We would tell them to fuck off and quite rightly so. We have our own free will to do what we choose and it is one thing you should never abuse or take for granted.

There are not many people who can give genuine opinions any kind of assesment of the two version unless they play unmodded base versions of OA. fromhell is no doubt one of them, I know Joki does and a few others who use the RN tourney server.

As far as I know the only thing different is the input in 0.7.7. Most other things are non applicable, I've been using the same delag functions that exist in 0.7.7 since day one using 0.7.1. In that respect there is no argument that many peoples comments are just a load of crap. However, on the other hand delag options are now available in the base game so people now have the oppertunity to play against opponents and with a much higher margin of ping. Actually, I think the same delag already might be on 0.7.1 because it is quake 2.01 netcode, but most importantly it's documented and enabled by default. Some people may not like it. Your movement will feel quite different.

The people who do not like the feel of 0.7.7 could just well be referring to the effects of the netcode and not the input code changes.  In which case the people who criticise 0.7.7 will not like my server on 0.71 either. It suits me perfectly Smiley

pulchr - do you have a server? If not then you will need to find out what it is you don't like.  I can possibly arrange a server where you click the middle mouse button and it will give you a range of settings and you just use scroll to select each mode - for it to work properly, you will need to set rate  10000,  cl_maxpackets 30, snaps 40. Some of the modes will force some minimum values, so you might have 125 maxpackets rather than 30 you have in your config.  Chances are it's config change and you can still play with the movement you want. However, you will need to find the servers which has a config more to your liking.
Logged
fufinha
stop making alt accounts and self-termination
Member


Cakes 7
Posts: 584


retired


« Reply #23 on: June 16, 2008, 05:34:03 AM »

ok I'm looking for 0.7.7 and cant find it. Please tell me the answer does not start with  0.7.6  Sad

I don't get it. That's the messed up one. That thing should be gone altogether, since it's the only version that is compatible with 0.7.1, with server help, and also compatible with 0.7.7 after an upgrade. wtf?

And while I like the idea of packaged updates as MrOoops suggested, instead of releasing a fix, why not put this as a download instead, just like was done with 0.7.6. Who cares if the evolution people have to download it again, they are only going to stab it in the back a few weeks later because its their own fault they didnt look where they were jumping
Logged
kick52
Member


Cakes -1
Posts: 229


« Reply #24 on: June 16, 2008, 06:37:10 AM »

FAO kick/aantipoop @ similar minded ppl : Your issue is over a lack of servers / players on 0.7.7. You don't really care about OA nor do you care about anything other than yourselves.

Excuse me while I finish eating the epic lolz you just served me.


Hmm, tasty.
Logged
Pages: [1] 2 3 ... 5
  Print  
 
Jump to: