Pages: [1]
  Print  
Author Topic: performance problems (on linux)  (Read 5338 times)
aantipop
Half-Nub


Cakes 3
Posts: 66


« on: November 10, 2008, 03:59:39 am »

hi!

i dont have a stable 125 fps with openarena. this happens on all versions, 071 and on. i tried different  engines but i have the problem with all of them.
my computer should run it smooth (amd dual core @ 3 ghz, nvidia 9600gt and 4 gig ddr2 ram (800mhz). other games run fine, sauerbraten with antialiasing  for example on high resolutions.
i dont have any fps drops when i use windows xp..

my distro is archlinux on x86_64, with the stock kernel and 177.80 drivers.

any idea what could cause these fps drops ?
espacially on spacemaps with many players it lags soo hard, its unplayable Sad
Logged
mathieu
Nub


Cakes 2
Posts: 24


WWW
« Reply #1 on: November 11, 2008, 02:34:32 am »

try to lower your graphic details
Logged
menganito
Lesser Nub


Cakes 7
Posts: 119


« Reply #2 on: November 11, 2008, 06:21:10 am »

I'd try turning High Quality sky off, if you have Compiz/other desktop compositor enblad, also try turning it off.
On that machine it should run smoothly, though.
Logged
kernel panic
Lesser Nub


Cakes 6
Posts: 114


« Reply #3 on: November 14, 2008, 06:43:42 am »

Aanti, I get the same thing. It's not that my computer can't handle it, it just happens out of the blue from time to time, going from stable 125 to a constant oscillation between 85 and 125 FPS. Sometimes restarting the video solves it temporarily. It happens to me much more often with the OSS drivers than with the propietary ones (I have an AMD card, though), but it still happens. I don't have Windows nor any other game installed, so I can't tell where the problem may be.

I don't remember where the hell I read something very similar having to do with the GART memory...but...I could've dreamt it...and fiddling with the this setting doesn't improve anything here.
« Last Edit: November 14, 2008, 06:46:17 am by kernel panic » Logged
Cacatoes
Banned for leasing own account
Posts a lot
*

Cakes 73
Posts: 1428


also banned for baiting another to violate rules


« Reply #4 on: November 14, 2008, 01:44:07 pm »

Also reminds me of some problem I had with my other computer, it had an NVIDIA card.
When the fan was on, performance was affected.
I investigated around cpufreq (the energy monitoring system) and such but even after I spent some time to configure it properly it didn't seem to help.
Logged

Todo: Walk the cat.
aantipop
Half-Nub


Cakes 3
Posts: 66


« Reply #5 on: November 16, 2008, 03:23:20 am »

i once recompiled a custom kernel and problems were gone, but the last times i tried it either didnt compile or i wasnt able to get the nvidia drivers to work with it.
Logged
christooss
Lesser Nub


Cakes 3
Posts: 121


« Reply #6 on: November 23, 2008, 05:20:06 pm »

I have noticed slow down on linux. Even if I put all things on Low quality (640x480)it still freezes from time to time in game.

I have really chopy sound to. Maybe those to are related?

I have intel based laptop (x3100 graphic card, 2GB ram) I have no such problems in windows. Any libopenal and libvorbis installed. Any ideas?
Logged
Cacatoes
Banned for leasing own account
Posts a lot
*

Cakes 73
Posts: 1428


also banned for baiting another to violate rules


« Reply #7 on: November 24, 2008, 02:59:06 am »

When I had choppy sound and low fps, was due to some USB or WIFI problem. (sometimes both occur at the same time)
Logged

Todo: Walk the cat.
aantipop
Half-Nub


Cakes 3
Posts: 66


« Reply #8 on: November 25, 2008, 10:53:42 am »

solved by adding "nopat" to kernel boot options in /boot/grub/menu.lst

Logged
Pages: [1]
  Print  
 
Jump to: