Pages: [1]
  Print  
Author Topic: CL.SNAP.SERVERTIME<CL.OLDFRAMESERVERTIME ERROR  (Read 5967 times)
JESUS SCOUSE
Half-Nub


Cakes -2
Posts: 89



« on: February 04, 2009, 07:41:48 pm »

CL.SNAP.SERVERTIME<CL.OLDFRAMESERVERTIME ERROR
Keep getting bombed out of some servers with the above error code.
It seems to be servers that run countdowns to game start.
If I make it into game when map changes before countdown reaches zero then it's OK.
If the game has started before I can join I get bombed out.
Any Ideas how to fix it?
Logged
damocles
Bigger member


Cakes 0
Posts: 158


May cause drowsiness


« Reply #1 on: February 04, 2009, 08:24:10 pm »

I have only noticed this with heavy load or low RAM (less than 512MB), where a map change would take longer than expected.  It is possible that a poor connection would also affect it.

Some places suggest setting snaps to 40 or reverting your config, but for others this doesn't change anything or it simply disappears on its own.  (I did not look very far.)
Logged
JESUS SCOUSE
Half-Nub


Cakes -2
Posts: 89



« Reply #2 on: February 05, 2009, 12:39:57 pm »

Snaps already set to 40
I have 256 Mb Ram so thats probably why.
Thanks for the help.
Logged
fufinha
stop making alt accounts and self-termination
Member


Cakes 7
Posts: 585


retired


« Reply #3 on: February 05, 2009, 01:15:30 pm »

if you have lots of maps try moving them somewhere else.. mibbe help?
Logged
dash9
Member


Cakes 6
Posts: 189


« Reply #4 on: March 28, 2009, 06:21:15 pm »

I also got this error, in an OSP server, when a new map was loading I think.
ERROR: cl.snap.serverTime < cl.oldFrameServerTime
I have the log in case anyone is interested.
Logged

I found a great camping place: the enemy base!
zed
Nub


Cakes 0
Posts: 5


« Reply #5 on: March 30, 2009, 05:05:16 pm »

It seems to be servers that run countdowns to game start.
If I make it into game when map changes before countdown reaches zero then it's OK.
If the game has started before I can join I get bombed out.
Any Ideas how to fix it?
In the case of RN|OSP, we also were plagued by this problem (clients randomly disconnect after a new map is loaded with log message was "ERROR: cl.snap.serverTime < cl.oldFrameServerTime"). We came to the same conclusion: the problem occurs if the client cannot load the new map within the specified warmup phase. Our solution was to disable warmup (g_dowarmup "0"). Alternatively, we could have set the length of the warmup phase to a bigger value (g_warmup "15").

Talk to the server's administrators about this problem. If that is not an option, your only choice is to speed up the loading of maps by your client. Buying memory might help. You could also follow the above advice of deleting maps/pk3 files of your ~/.openarena/baseoa directory that you don't play very often (move them temporarily to a backup folder to test the effect).

« Last Edit: March 30, 2009, 05:45:08 pm by zed » Logged
JESUS SCOUSE
Half-Nub


Cakes -2
Posts: 89



« Reply #6 on: April 18, 2009, 10:01:00 am »

Thanks zed. Since I posted I have not found any servers that use the warmup. I have now got 512Mb ram (wow) and map restarts are very quick. I even see other players appear which I never had before. Again thanks for the help.
Logged
Cacatoes
Banned for leasing own account
Posts a lot
*

Cakes 73
Posts: 1428


also banned for baiting another to violate rules


« Reply #7 on: October 03, 2009, 01:15:55 pm »

Got this problem on ROFL Various Couscous too, warmup time is 5 seconds, so as I have a poor connection here I'm kicked.

I'll extend warmup time, although if there was some way to fix that software-side that would have been nice, maybe I should complain to ioquake3 ? Wink
Logged

Todo: Walk the cat.
Pages: [1]
  Print  
 
Jump to: