Pages: [1] 2
  Print  
Author Topic: server port problem  (Read 17842 times)
lparcshinoda
Nub


Cakes 0
Posts: 33


Cetramod.it Webmaster


WWW
« on: June 28, 2009, 01:49:43 PM »

I've setted my dedicated server (Cetramod.it OpenArena Server) but it says a number port different than 27960 (the default one) in the masterlist http://dpmaster.deathmask.net/index.php?game=openarena. What's the problem ? I used the setting of net_port and net_qport to 27960 too but it didn't worked. HELP.
Logged

Cetramod.it // An italian homeground for both Final Fantasy VII and OpenArena players
Cacatoes
Banned for leasing own account
Posts a lot
*

Cakes 73
Posts: 1427


also banned for baiting another to violate rules


« Reply #1 on: June 28, 2009, 01:57:54 PM »

Do you pass them in the command line, or through inside the .cfg ?
You should try with command-line Wink

Also, check your port isn't already used by another server/application.

And finally, sometimes autoexec.cfg files conflicts with what you put in your server config. If autoexec starts the server first and uses the port, then you won't have the correct port set.
Logged

Todo: Walk the cat.
lparcshinoda
Nub


Cakes 0
Posts: 33


Cetramod.it Webmaster


WWW
« Reply #2 on: June 28, 2009, 01:59:16 PM »

oa_ded.exe +set dedicated 2 +set net_port 27960 +set net_qport 27960 +exec server.cfg

the port setting is just here Wink

now I'll check the used ports
Logged

Cetramod.it // An italian homeground for both Final Fantasy VII and OpenArena players
sago007
Posts a lot
*

Cakes 62
Posts: 1664


Open Arena Developer


WWW
« Reply #3 on: June 28, 2009, 02:19:17 PM »

You should not set qport at all. It is a hack to solve a problem with cheap many-to-one NAT routers.
Logged

There are nothing offending in my posts.
lparcshinoda
Nub


Cakes 0
Posts: 33


Cetramod.it Webmaster


WWW
« Reply #4 on: June 28, 2009, 02:34:15 PM »

nothing solved Sad
Logged

Cetramod.it // An italian homeground for both Final Fantasy VII and OpenArena players
davidd
Half-Nub


Cakes 6
Posts: 99


[Z] server maintainer


« Reply #5 on: June 29, 2009, 05:22:12 AM »

I looked at the master list but could not find you server....

My guess is that your computer is not on the real internet but behind a NAT box.

what does you computer think its ip is?
look at properties of your network connection to see what your ip is

than step 2. go to http://www.whatismyip.com/ and see if it is the same number.

If they are the same, then i dont know what the problem is.
If they are different, then that is the problem.
Logged

Openarena, the freedom to contribute and extend.
lparcshinoda
Nub


Cakes 0
Posts: 33


Cetramod.it Webmaster


WWW
« Reply #6 on: June 29, 2009, 11:54:27 AM »

http://dpmaster.deathmask.net/index.php?game=openarena&server=82.55.217.84:29602

the server is on the list. I'm not behind a NAT, but the port used to connect for OA ded Server is always different .. about a range of 19000 - 30000.
Logged

Cetramod.it // An italian homeground for both Final Fantasy VII and OpenArena players
sago007
Posts a lot
*

Cakes 62
Posts: 1664


Open Arena Developer


WWW
« Reply #7 on: June 29, 2009, 01:09:37 PM »

What does you startup command look like?
Logged

There are nothing offending in my posts.
lparcshinoda
Nub


Cakes 0
Posts: 33


Cetramod.it Webmaster


WWW
« Reply #8 on: June 30, 2009, 01:50:04 AM »

oa_ded.exe +set dedicated 2 +set net_port 27960 +exec server.cfg
Logged

Cetramod.it // An italian homeground for both Final Fantasy VII and OpenArena players
lparcshinoda
Nub


Cakes 0
Posts: 33


Cetramod.it Webmaster


WWW
« Reply #9 on: July 02, 2009, 08:53:16 AM »

up please !!

note that the server returns this

Code:
"net_port" is:"27960^7", the default

to enter the server people are using the "specify command" are using the IP:PORT as showed on the masterserv and not with 27960 port as the server says
Logged

Cetramod.it // An italian homeground for both Final Fantasy VII and OpenArena players
Falkland
Member


Cakes 6
Posts: 590


« Reply #10 on: July 02, 2009, 09:27:01 AM »

up please !!

note that the server returns this

Code:
"net_port" is:"27960^7", the default

to enter the server people are using the "specify command" are using the IP:PORT as showed on the masterserv and not with 27960 port as the server says

- Are you completely sure u are not behind a NAT/router ?
- Are u on a virtual server or so ?
- Does the server allow direct port opening or does it act as a NAT ? ( mapped ports on the virtual net device are different of the real ports opened by the server to internet ) ?
- Is the UDP port 27960 allowed for incoming connection and not blocked ?
Logged
lparcshinoda
Nub


Cakes 0
Posts: 33


Cetramod.it Webmaster


WWW
« Reply #11 on: July 04, 2009, 08:57:47 AM »

- Are you completely sure u are not behind a NAT/router ?

I'm behind a router

- Are u on a virtual server or so ?

No virtual server settings interfere with OA ports

- Does the server allow direct port opening or does it act as a NAT ? ( mapped ports on the virtual net device are different of the real ports opened by the server to internet ) ?

NAT is enabled so I guess that's the problem ... it never caused problems with OA on my old router ... i changed it lately so I guess that's it. I guess I have to set a virtual server entry ... maybe an UDP mapping of port 27960 on my LOCAL ip (192.168.1.2) ... I tryed but it didn't solve.

- Is the UDP port 27960 allowed for incoming connection and not blocked ?

yes. I don't use any firewall (neither HW nor SW).

Logged

Cetramod.it // An italian homeground for both Final Fantasy VII and OpenArena players
Falkland
Member


Cakes 6
Posts: 590


« Reply #12 on: July 04, 2009, 09:01:17 AM »

I'm behind a router

You have to explicitely forward the port 27960 also on the router.
Logged
lparcshinoda
Nub


Cakes 0
Posts: 33


Cetramod.it Webmaster


WWW
« Reply #13 on: July 04, 2009, 09:04:20 AM »


I guess I have to set a virtual server entry ... maybe an UDP mapping of port 27960 on my LOCAL ip (192.168.1.2) ... I tryed but it didn't solve.


Logged

Cetramod.it // An italian homeground for both Final Fantasy VII and OpenArena players
Falkland
Member


Cakes 6
Posts: 590


« Reply #14 on: July 04, 2009, 09:10:34 AM »

I guess I have to set a virtual server entry ... maybe an UDP mapping of port 27960 on my LOCAL ip (192.168.1.2) ... I tryed but it didn't solve.

Yes ... u have to select the Port Forwarding Option on the router , select your LOCAL IP and forwarding the port 27960.

If the final port showed on the dpmaster is different maybe the problem could be caused by the UnP service.

EDIT : try to set the start port to 27950 , since it's used to send heartbeat to the dpmaster.
Logged
sago007
Posts a lot
*

Cakes 62
Posts: 1664


Open Arena Developer


WWW
« Reply #15 on: July 04, 2009, 09:16:19 AM »

It works.

It still sends a random port number to the master server but connecting on both ports work. This suggests that the router supports the Quake 3 server extension.

http://dpmaster.deathmask.net/?game=openarena&server=82.53.174.40:27960

EDIT: Not working anymore
Logged

There are nothing offending in my posts.
lparcshinoda
Nub


Cakes 0
Posts: 33


Cetramod.it Webmaster


WWW
« Reply #16 on: July 04, 2009, 09:19:16 AM »

so, it works but keeps using a random port ... using this URL http://dpmaster.deathmask.net/?game=openarena&server=82.53.174.40:27960 I cannot access server stats ... I need to use a sort of RANDOM url depending on the port ... isn't there a way to solve this ?

Thanks a Lot ^^
Logged

Cetramod.it // An italian homeground for both Final Fantasy VII and OpenArena players
sago007
Posts a lot
*

Cakes 62
Posts: 1664


Open Arena Developer


WWW
« Reply #17 on: July 04, 2009, 09:27:04 AM »

You might want to see if "Quake 3" is an option in the application list in your router. The fact that it works out of the box suggest that the router knows how to handle Quake 3 servers but being a PAT router it assumes complete control on external ports.
Logged

There are nothing offending in my posts.
lparcshinoda
Nub


Cakes 0
Posts: 33


Cetramod.it Webmaster


WWW
« Reply #18 on: July 04, 2009, 09:30:32 AM »

being a PAT router it assumes complete control on external ports

so I can't set this ? I haven't found anything similar on my router interface
Logged

Cetramod.it // An italian homeground for both Final Fantasy VII and OpenArena players
sago007
Posts a lot
*

Cakes 62
Posts: 1664


Open Arena Developer


WWW
« Reply #19 on: July 04, 2009, 09:42:12 AM »

so I can't set this ?
It should be possible. I don't understand why the virtual server does not work.

Some guides on the Internet suggest that certain routers might need a few extra ports to get them to behave (sound not right to me). What router do you have?
Logged

There are nothing offending in my posts.
Falkland
Member


Cakes 6
Posts: 590


« Reply #20 on: July 04, 2009, 09:53:24 AM »

Some guides on the Internet suggest that certain routers might need a few extra ports to get them to behave (sound not right to me). What router do you have?

When I've tried to setup a little server , I had such this problem ... but for me the server was marked as unreachable in the dpmaster list .

I've solved when I've set the Start port number to 27950 :

- Start Port Number 27950
- End Port Number 27960
- Port Mapping 27950

Finally the server was correctly showed in the dpmaster list as reachable.
Logged
lparcshinoda
Nub


Cakes 0
Posts: 33


Cetramod.it Webmaster


WWW
« Reply #21 on: July 04, 2009, 09:56:13 AM »

Trust Wireless ADSL2+ Router (15898)

http://www.trust.com/products/product.aspx?artnr=15898

My settings are

port start: 27950
port end: 27960

and it keeps being random.
Logged

Cetramod.it // An italian homeground for both Final Fantasy VII and OpenArena players
Falkland
Member


Cakes 6
Posts: 590


« Reply #22 on: July 04, 2009, 10:17:29 AM »

Mmm ... I don't think that Telecom Italia is blocking UDP port 27960 , isn't it ?
Logged
sago007
Posts a lot
*

Cakes 62
Posts: 1664


Open Arena Developer


WWW
« Reply #23 on: July 04, 2009, 10:45:46 AM »

Trust Wireless ADSL2+ Router (15898)
My settings are

port start: 27950
port end: 27960
The guide on portforward.com does not have your specific router but suggests that including port 27965 is needed (I have no idea why) and that NAT must be enabled too.
Logged

There are nothing offending in my posts.
lparcshinoda
Nub


Cakes 0
Posts: 33


Cetramod.it Webmaster


WWW
« Reply #24 on: July 04, 2009, 10:52:37 AM »

NAT is enabled and Telecom Italia (my ISP) is not blocking any port ... I was using a D-link before and OA was workinf perfectly.



nothing changed

http://dpmaster.deathmask.net/?game=openarena&server=79.53.233.101:10052
Logged

Cetramod.it // An italian homeground for both Final Fantasy VII and OpenArena players
Pages: [1] 2
  Print  
 
Jump to: