Pages: [1] 2 3
  Print  
Author Topic: OpenArena v0.8.5  (Read 40064 times)
fromhell
Administrator
GET A LIFE!
**********

Cakes 34
Posts: 14506



WWW
« on: October 21, 2009, 07:12:30 am »

Since 0.9.0 is still miles off (100% texture replacement may not be this year), I am planning a new patch version this month, and hopefully I want to make it as small as possible. It's more of a maintenance release than anything else. v0.8.1 is just about one year old!

The gist of it:
- New engine binaries and new VMs with the fixes and such since 0.8.1
- Probably extra maps that don't add a lot of textures.
- The new icon / logo
- New major, sorceress, neko, angelyss, etc won't be in this version
- Drastic new sound changes...won't be in this version.
- Win32 installer may or may not return, maybe NSIS will be used this time around.

Any other things needed to be included?
Logged

asking when OA3 will be done won't get OA3 done.
Progress of OA3 currently occurs behind closed doors alone

I do not provide technical support either.

new code development on github
Neon_Knight
In the year 3000
***

Cakes 49
Posts: 3763


Trickster God.


« Reply #1 on: October 21, 2009, 07:58:02 am »

- What about the new UI for the menu?
- Any sound changes should go IMHO.
- The latest version of OAX too.
- Is there a release date for it? I have small time on these days, (this week and the next) but I can work with Udi for the new 2D, and I can work too on the shaders.

Will you post this on ModDB? Tongue
Logged


"Detailed" is nice, but if it gets in the way of clarity, it ceases being a nice addition and becomes a problem. - TVT
Want to contribute? Read this.
fromhell
Administrator
GET A LIFE!
**********

Cakes 34
Posts: 14506



WWW
« Reply #2 on: October 21, 2009, 08:23:42 am »

- What about the new UI for the menu?
Maybe i'll have that. The media files for that is quite small so it's not an impossibility.

- Any sound changes should go IMHO.
- The latest version of OAX too.
"Go" as in go away or go be a part of the patch?
Logged

asking when OA3 will be done won't get OA3 done.
Progress of OA3 currently occurs behind closed doors alone

I do not provide technical support either.

new code development on github
Neon_Knight
In the year 3000
***

Cakes 49
Posts: 3763


Trickster God.


« Reply #3 on: October 21, 2009, 08:29:32 am »

"Go" as being part of the patch, of course.
This sound will be included as well? Cheesy
Logged


"Detailed" is nice, but if it gets in the way of clarity, it ceases being a nice addition and becomes a problem. - TVT
Want to contribute? Read this.
fromhell
Administrator
GET A LIFE!
**********

Cakes 34
Posts: 14506



WWW
« Reply #4 on: October 21, 2009, 08:31:11 am »

NO! THATS AN INFERIOR REPLACEMENT!!!




yes replacing obviously crappy sounds is vital
Logged

asking when OA3 will be done won't get OA3 done.
Progress of OA3 currently occurs behind closed doors alone

I do not provide technical support either.

new code development on github
Cacatoes
Banned for leasing own account
Posts a lot
*

Cakes 73
Posts: 1428


also banned for baiting another to violate rules


« Reply #5 on: October 21, 2009, 02:14:07 pm »

Hmm, why not putting in everything you can provided it's coherent ?
Since you change binaries, I'm not sure of why you shouldn't include every assets/maps you can. (to spare a few of these new things for the 0.9.0 release ? Wink I think meanwhile there will have enough time to get other things which would still make 0.9.0 a huge step forward)
A new version would indeed be welcome, I'd vote for the maximum, even if rather looks like a 0.8.8 rather than a 0.8.5, maybe you can get OA more polished even before 0.9.0.
Just my opinion Wink
Logged

Todo: Walk the cat.
Neon_Knight
In the year 3000
***

Cakes 49
Posts: 3763


Trickster God.


« Reply #6 on: October 21, 2009, 02:21:18 pm »

It'll weigh too much, nearly 78 or 85 MB in just one PK3. Imagine if you must download that from a server having 0.8.1.
Logged


"Detailed" is nice, but if it gets in the way of clarity, it ceases being a nice addition and becomes a problem. - TVT
Want to contribute? Read this.
fromhell
Administrator
GET A LIFE!
**********

Cakes 34
Posts: 14506



WWW
« Reply #7 on: October 21, 2009, 02:46:21 pm »

If someone's going to automatically download the patch off a server with v0.8.1 the VM's UI should suggest the full v0.8.5 patch for the engine fixes.
Logged

asking when OA3 will be done won't get OA3 done.
Progress of OA3 currently occurs behind closed doors alone

I do not provide technical support either.

new code development on github
Neon_Knight
In the year 3000
***

Cakes 49
Posts: 3763


Trickster God.


« Reply #8 on: October 21, 2009, 04:10:44 pm »

Then, there should be some way to make the VMs to detect the right binaries to have...
Logged


"Detailed" is nice, but if it gets in the way of clarity, it ceases being a nice addition and becomes a problem. - TVT
Want to contribute? Read this.
sago007
Posts a lot
*

Cakes 62
Posts: 1664


Open Arena Developer


WWW
« Reply #9 on: October 21, 2009, 05:03:28 pm »

Then, there should be some way to make the VMs to detect the right binaries to have...
It doesn't really matter. There has not been any new functionality added to the binaries, so the old ones will work just fine. Sure the number of CVARs supported has been significantly increased but it is mostly relevant for mods.

There can be added support for engine detection... but I don't think it is worth it for the time being.
Logged

There are nothing offending in my posts.
tuppe666
Nub


Cakes 0
Posts: 44

Member


« Reply #10 on: October 22, 2009, 12:40:02 pm »

Fonts and UI please as this is something that would give a wonderful first impression.

I'm not sure what limiting the download will make. once your hitting 85mb your in broadband territory. If its time/quality concerns I could understand.


Logged
Mr. D
Nub


Cakes 0
Posts: 11



« Reply #11 on: October 22, 2009, 01:15:57 pm »

- Probably extra maps that don't add a lot of textures.

New maps and new upgrades of them are surely one of the most welcome
Logged

(Sorry for my bad English...)
dbX
Member


Cakes 11
Posts: 199

Shazpaca!


WWW
« Reply #12 on: October 22, 2009, 04:13:13 pm »

I think any update is better than no update. At least something to keep me busy until the next update.

Personally, size of the update is not that important. Not that I have a lot of bandwidth to waste, but it's something I'll download once, and not on a weekly or daily basis, so it does not make that much of a impact over longer period of time.

As to what to put in the update, I don't know, whatever seems most sensible and can be done in time.

As for the installer, it's not that important. It's pretty easy to extract the archive and make a shortcut, at least for Windows. If you cannot do that then you might want to learn something about using computers.
Logged

In defeat we learn.
BCH32
Nub


Cakes 1
Posts: 10



« Reply #13 on: October 26, 2009, 03:32:40 am »

I think any update is better than no update. At least something to keep me busy until the next update.

Personally, size of the update is not that important. Not that I have a lot of bandwidth to waste, but it's something I'll download once, and not on a weekly or daily basis, so it does not make that much of a impact over longer period of time.

As to what to put in the update, I don't know, whatever seems most sensible and can be done in time.

As for the installer, it's not that important. It's pretty easy to extract the archive and make a shortcut, at least for Windows. If you cannot do that then you might want to learn something about using computers.
I'm agree with dbx, size is not a big problem as far it's not a Go update.
And I alway prefer DL an archive than an installer. With an archive you can handle easyly more than one version.
I Think you should put the maximum of thing in this update.

« Last Edit: October 26, 2009, 03:48:54 am by BCH32 » Logged
Neon_Knight
In the year 3000
***

Cakes 49
Posts: 3763


Trickster God.


« Reply #14 on: October 26, 2009, 07:45:59 am »

Any release date of this patch? We're near the end of the month, I'm doing a bit of work in some of my maps.
Logged


"Detailed" is nice, but if it gets in the way of clarity, it ceases being a nice addition and becomes a problem. - TVT
Want to contribute? Read this.
jackoverfull
Member


Cakes 14
Posts: 385


Member


WWW
« Reply #15 on: October 26, 2009, 05:52:29 pm »

This month?

Oook…just seen the topic…

Will have to setup a building environment (last year's one do not exists anymore), will start shortly. Call me when the sources are ready, I can do the Mac version as usual.
Logged
fromhell
Administrator
GET A LIFE!
**********

Cakes 34
Posts: 14506



WWW
« Reply #16 on: October 27, 2009, 11:06:26 am »

Any release date of this patch? We're near the end of the month, I'm doing a bit of work in some of my maps.
31 at the latest.
Logged

asking when OA3 will be done won't get OA3 done.
Progress of OA3 currently occurs behind closed doors alone

I do not provide technical support either.

new code development on github
Udi
Member


Cakes 25
Posts: 536


i do my own stunts


WWW
« Reply #17 on: October 27, 2009, 02:36:13 pm »

31 at the latest.

31th October? Holy shhh... I hope you don't want to scare the kids with an ugly release this Halloween Smiley. But alright, I go back to work now. *Igor! Pull the switch!*
Logged

http://udionline.hu/en/projektek/openarena/
Todo list: 1. q3dm17 textures replacement (95% done)
Neon_Knight
In the year 3000
***

Cakes 49
Posts: 3763


Trickster God.


« Reply #18 on: October 27, 2009, 02:37:26 pm »

31/10/2008 was the release date of 0.8.1.
I hope to get something finished before that date.
Logged


"Detailed" is nice, but if it gets in the way of clarity, it ceases being a nice addition and becomes a problem. - TVT
Want to contribute? Read this.
Neon_Knight
In the year 3000
***

Cakes 49
Posts: 3763


Trickster God.


« Reply #19 on: October 28, 2009, 08:13:12 am »

Question for fromhell:
Which maps will be in 0.8.5, aside of the 0.8.1 ones?
Logged


"Detailed" is nice, but if it gets in the way of clarity, it ceases being a nice addition and becomes a problem. - TVT
Want to contribute? Read this.
fromhell
Administrator
GET A LIFE!
**********

Cakes 34
Posts: 14506



WWW
« Reply #20 on: October 28, 2009, 09:51:52 am »

The ones that don't use many new textures.

oa_minia (newer version)
oa_koth2
the two reptctfs
am_underworks
the improved Hydronex
blitzkrieg3
Logged

asking when OA3 will be done won't get OA3 done.
Progress of OA3 currently occurs behind closed doors alone

I do not provide technical support either.

new code development on github
jackoverfull
Member


Cakes 14
Posts: 385


Member


WWW
« Reply #21 on: October 28, 2009, 12:16:20 pm »

I've finished setting up my new building enviroment, it is all working now, however I still have a problem, tried to solve it but no luck so far.

I'm now building the game on a G4 with Leopard, I used to build it on the same G4, but with tiger. The problem is that the resulting binary can't run on G3s, I get

Code:
incompatible cpu-subtype

at run time.

It may seem pointless to build OA for a platform that reached end of production over 5 years ago, but it still runs very well on recent G3s and I don't plan to abandon them soon. Any suggestion?
In the worst case I'll setup a building environment on a Tiger system somewhere.
Logged
Falkland
Member


Cakes 6
Posts: 590


« Reply #22 on: October 28, 2009, 12:27:14 pm »


I'm now building the game on a G4 with Leopard, I used to build it on the same G4, but with tiger. The problem is that the resulting binary can't run on G3s, I get

Code:
incompatible cpu-subtype

at run time.


Could it be related to this ? -> http://icculus.org/pipermail/quake3-commits/2009-October/001608.html
Logged
jackoverfull
Member


Cakes 14
Posts: 385


Member


WWW
« Reply #23 on: October 28, 2009, 12:35:52 pm »

I don't think so: i'm still using oa 0.8.1 sources, wich ran just fine on a G3 last time I built them on Tiger.
Logged
Falkland
Member


Cakes 6
Posts: 590


« Reply #24 on: October 28, 2009, 12:43:43 pm »

I don't think so: i'm still using oa 0.8.1 sources, wich ran just fine on a G3 last time I built them on Tiger.

Maybe there was a change in the Leopard SDK ... it seems me to understand that Leopard has dropped G3 support :/
Logged
Pages: [1] 2 3
  Print  
 
Jump to: