Pages: [1]
  Print  
Author Topic: Is there a default AI that bots use?  (Read 3811 times)
tosk1
Nub


Cakes 1
Posts: 20



« on: February 17, 2010, 03:11:07 AM »

Hi! Long time lurker, first time poster...

Followed the link in the useful links section, and added a couple of models from the ioquake website. When I play against bots, the new ones have a tendency to wait in the middle of nowhere for no apparent reason, and only react when I come into their field of view.

It doesn't bother me much, it means I can laugh as I walk up right behind one and blow their head off with a shotgun, and the openarena bots work normally so there's no problem with them (which is the most important thing).

Is this a default AI that models revert to when there's none supplied with the model? Or is it just the AI that was programmed in by the model makers?

I'm not raising an issue with the ioquake models, because I know this isn't the place to ask those questions. I was just curious as to why the models would act like this.
Logged

Dreamcast at car boot sale - £4
Quake 3 disc from 2nd hand shop - £3
Dreamcast Keyboard and mouse - £8
42" LCD TV - £400

Having an awesome old school Q3 gaming rig - Priceless
tosk1
Nub


Cakes 1
Posts: 20



« Reply #1 on: February 17, 2010, 05:10:38 AM »

Actually I think I may have found the answer. After browsing this forum, it seems Q3 AI doesn't have the ability to use certain OA weapons (missionpack weapons? Or something like that). And while playing I get a lot of "Error: Weapon number out of bounds" (or something like that) messages. So it may be that the models get stuck whenever they encounter a weapon that they can't use.

Does that sound logical? Can anyone confirm for me?

I wonder if I can get round this problem by filling all open slots with bots Smiley Even if they all have this problem, there will be so many bots blowing each other to kingdom come that as soon as one gets stuck, it will be respawned.

Logged

Dreamcast at car boot sale - £4
Quake 3 disc from 2nd hand shop - £3
Dreamcast Keyboard and mouse - £8
42" LCD TV - £400

Having an awesome old school Q3 gaming rig - Priceless
Graion Dilach
Member


Cakes 12
Posts: 403



« Reply #2 on: February 17, 2010, 12:45:44 PM »

Actually, you're right that the bot can't use the weapons. But not some weapons became corrupted. All of them, including powerups... everything.

Quake 3 and OpenArena users different names for the items in the botfiles, so to fix that error, you have to rewrite the bot's _w.c and _i.c (plain texts) located under the bot's pk3 (which is just a renamed zip) botfiles\bots folder, using a similar file from the default OA bots as a base (pak6-misc.pk3\botfiles\bots).

The Missionpack entities (chaingun, dom point, whatever) are also missing,you have to come up with their numbers, but the rest are commented enough to understand and see the changes. (For example, W_GRENADELAUNCHER to GLW) etc.

I wouldn't consider this as the model maker's fault, nor anybody elses. It's two different game, thereby it needs a conversion.

Interestingly, they don't stuck without the conversion... they just use the MG and nothing more.
Logged

One shall remind what have he left behind... to actually realize that it's still cool.
Pages: [1]
  Print  
 
Jump to: