Pages: 1 2 3 [4] 5 6 ... 11
  Print  
Author Topic: 0.8.5 Bugs  (Read 42095 times)
PWNAGE
Half-Nub


Cakes 0
Posts: 90


LEWL!


WWW
« Reply #75 on: June 08, 2010, 03:58:22 am »

Im not sure if this one has been said but when i go multiplayer i have to sort by "Human Players" every time. it should just stay set like that like "Show Empty"

I like to have my settings as:
Show Empty: OFF
Sort By: Human Players

But every time i go back its set to Sort By: "Ping Time"
Logged

OPEN ARENA!!!!... it's cool

-PWNAGE- Anonymous Browsing
Gig
In the year 3000
***

Cakes 45
Posts: 3197


WWW
« Reply #76 on: June 22, 2010, 01:55:16 am »

Hello, I noticed a bug with lightning gun. I suppose it is not so big, but anyway it should be fixed, I think...

Well, I was playing Elimination mode (or maybe some other mode with g_elimination enabled, I don't remember), and I have been killed when I was using lightning gun. I entered the game again, and immediately fired with lightning gun... and I saw another beam, starting from my own "old" corpse (that wasn't gibbed), that aimed at the same point I was aiming.

See the first screenshot: the left beam comes from my old corpse, that is not visible because it is disappearing underground.
In the second screenshot: I see that I can fire with lightning gun even when I'm dead, before respawning. I wonder if that ray can hurt someone...

I thought the only item usable when you are dead was Kamikaze... isn't so?
« Last Edit: June 23, 2010, 04:08:16 am by Gig » Logged

I never want to be aggressive, offending or ironic with my posts. If you find something offending in my posts, read them again searching for a different mood there. If you still see something bad with them, please ask me infos. I can be wrong at times, but I never want to upset anyone.
chaoticsoldier
Member


Cakes 18
Posts: 376


This space intentionally left blank.


« Reply #77 on: June 23, 2010, 03:32:22 am »

I'm guessing the second lightning beam does do damage. Here's why:

I tested it out with other weapons in Elimination mode and found this bug works with the gauntlet as well. When I held down fire after I died, the gauntlet sound was still playing. Sometimes I could still see the blade spinning just before I respawned.

I played around with some bots and after a bot killed me I could still cause damage to it before the next round began. Check out the attached demo.
Logged

0101100101101111011101010010011101110110011001010010000001101010011101010111001101110100001000000111011101100001011100110111010001100101011001000010000001111001011011110111010101110010001000000111010001101001011011010110010100101110
Gig
In the year 3000
***

Cakes 45
Posts: 3197


WWW
« Reply #78 on: June 25, 2010, 06:32:08 am »

Im not sure if this one has been said but when i go multiplayer i have to sort by "Human Players" every time. it should just stay set like that like "Show Empty"

I like to have my settings as:
Show Empty: OFF
Sort By: Human Players

But every time i go back its set to Sort By: "Ping Time"

Well, I found here that the two variables are ui_browserShowEmpty <0 or 1> and ui_browserSortKey <number>. They are saved inside your q3config.cfg file, I see. So if you change them, the next time you open OpenArena, will see the last values used. Try to sort for "map name", exit OpenArena and then launch it again: you will find "map name". It seems to work for ui_browsersortkey 1, 2, 3, 4, those from Quake 3 Arena (0=Server Name 1=Map Name 2=Open Player Spots 3=Game Type 4=PingTime). "Sort by human players" is 5, and probably it is not included in the original Q3A, and was added in ioquake3 or OpenArena (I don't know)... and there is a bug. "5" is correctly stored in the configuration file, but when you enter the "multiplayer" menu, that value works like if not allowed, and the program sorts for "ping" (ping is value 4, the default).

It's a bug... I don't know if from ioquake3 or OpenArena...
Logged

I never want to be aggressive, offending or ironic with my posts. If you find something offending in my posts, read them again searching for a different mood there. If you still see something bad with them, please ask me infos. I can be wrong at times, but I never want to upset anyone.
sago007
Posts a lot
*

Cakes 51
Posts: 1482


Open Arena Modder/Player


WWW
« Reply #79 on: June 25, 2010, 10:23:11 am »

It's a bug... I don't know if from ioquake3 or OpenArena...
It is from OpenArena. The only in game menu change that ioquake3 did (and that I know of) is the support for multiple master servers and the credits screen.

The value is likely clamped in the beginning on the code... a good example on how many places things can go wrong then editing the classic UI.
Logged

There are nothing offending in my posts. See http://www.wired.com/news/technology/0,70179-0.html for details
Gig
In the year 3000
***

Cakes 45
Posts: 3197


WWW
« Reply #80 on: June 28, 2010, 04:03:57 pm »

Similar problem for "hide private": you find it "on", also if you disabled it the previous time you used openarena...

PS: In English, is more correct "only humans" or "humans only"?
Logged

I never want to be aggressive, offending or ironic with my posts. If you find something offending in my posts, read them again searching for a different mood there. If you still see something bad with them, please ask me infos. I can be wrong at times, but I never want to upset anyone.
chaoticsoldier
Member


Cakes 18
Posts: 376


This space intentionally left blank.


« Reply #81 on: June 29, 2010, 06:58:28 pm »

PS: In English, is more correct "only humans" or "humans only"?
"only humans"
As a general rule, adjectives come before nouns, but there are many exceptions. In this case, "humans only" also makes perfect sense.
Logged

0101100101101111011101010010011101110110011001010010000001101010011101010111001101110100001000000111011101100001011100110111010001100101011001000010000001111001011011110111010101110010001000000111010001101001011011010110010100101110
Gig
In the year 3000
***

Cakes 45
Posts: 3197


WWW
« Reply #82 on: June 30, 2010, 01:14:03 am »

PS: In English, is more correct "only humans" or "humans only"?
"only humans"
As a general rule, adjectives come before nouns, but there are many exceptions. In this case, "humans only" also makes perfect sense.
I don't know exactly why, but in my mind I thought something like "We are only humans" (meaning "simply humans"), "We are the only humans here".... but "Access reserved to humans only"....
"Show only humans"... "Show humans only"... "only" doesn't seem an adjective (it doesn't specify "how" these humans are), but I don't know exaclty what it is...
Logged

I never want to be aggressive, offending or ironic with my posts. If you find something offending in my posts, read them again searching for a different mood there. If you still see something bad with them, please ask me infos. I can be wrong at times, but I never want to upset anyone.
chaoticsoldier
Member


Cakes 18
Posts: 376


This space intentionally left blank.


« Reply #83 on: June 30, 2010, 11:20:49 pm »

"Only" is a hard one. English can be very confusing sometimes.

"We are only humans" (meaning "simply humans")
In this context it qualifies as an adverb. Here, "only" is synonymous with "merely", "just" or "simply".


When expressing singularity, "only" is an adjective.

"Access reserved to humans only"....
"Show only humans"...
"Show humans only"...
"We are the only humans here"....
In these cases "only" is an adjective because it specifies the humans are not with anything else or are separate from something else. Here, "only" means the same as "alone" or "nothing else".

So it's more like:
"Access reserved to humans alone/and nothing else"
"Show nothing else but humans"
"Show humans alone/and nothing else"
"We alone/and nothing else are the humans here"
Logged

0101100101101111011101010010011101110110011001010010000001101010011101010111001101110100001000000111011101100001011100110111010001100101011001000010000001111001011011110111010101110010001000000111010001101001011011010110010100101110
Gig
In the year 3000
***

Cakes 45
Posts: 3197


WWW
« Reply #84 on: July 02, 2010, 03:25:00 am »

Another couple of bugs:
- A small flaw in "bloom" graphic feature. It seems something like some "bloom" effects on the right side of the screen are someway "reflected" on the first pixels of the screen, on the left (maybe they "exit" outside the screen and re-enter on the other side). Look at the attached image, form oa_shine map. Do you see the azure-blue glow on the left edge? It's related to the triangle of the jump-pad on the right... A similar thing happens when you are using railgun and you are moving: looking carefully, you can notice a small white glow moving on the lower left of the screen (not in this screenshot because I wasn't moving).

UPDATE: the bug is much more evident in the SLIMEFAC map, and involves all the four edges of the screen.

- "\exec" command uses autocomplete feature: when you write "\exec a" and then press TAB key, the console will list your .cfg files beginning with "a", or, if there is only one matching, will select it. And it's very useful. The problem is that this autocomplete feature works when you are on the main menu, but after you enter a match, it does not work anymore (and it selects default.cfg if I push TAB two times... strange).

UPDATE: Bug also reported to the ioquake3 staff, as bug 4794.

- PS: About railgun... a thing, not related to the "bloom" problem above... The semi-transparent layer protruding (seeming outside) from its chassis does not look very good... is it possible to fix the weapon model somehow?
« Last Edit: November 08, 2010, 03:17:53 pm by Gig » Logged

I never want to be aggressive, offending or ironic with my posts. If you find something offending in my posts, read them again searching for a different mood there. If you still see something bad with them, please ask me infos. I can be wrong at times, but I never want to upset anyone.
Marble of Doom
Bigger member


Cakes 4
Posts: 151

Caketastic


« Reply #85 on: July 02, 2010, 09:16:00 pm »




- A small flaw in "bloom" graphic feature. It seems something like some "bloom" effects on the right side of the screen are someway "reflected" on the first pixels of the screen, on the left (maybe they "exit" outside the screen and re-enter on the other side). Look at the attached image, form oa_shine map. Do you see the azure-blue glow on the left edge? It's related to the triangle of the jump-pad on the right...

I've noticed the bloom bug as well.

...The semi-transparent layer protruding (seeming outside) from its chassis does not look very good...

I think the  transparent layer is apart of a semi-transparent dome on the top of the glowy part on the gun. I agree it does not look very good. IMO the railgun needs a new model it's an ugly gun.
Logged

fromhell
Administrator
GET A LIFE!
**********

Cakes 13
Posts: 13905



WWW
« Reply #86 on: July 02, 2010, 09:25:49 pm »

It's hard to come up with a railgun without looking too much like a railgun. Sad
Logged
Gig
In the year 3000
***

Cakes 45
Posts: 3197


WWW
« Reply #87 on: July 05, 2010, 12:55:12 am »

I like this railgun instead... I'd simply like to fix that particular...
Logged

I never want to be aggressive, offending or ironic with my posts. If you find something offending in my posts, read them again searching for a different mood there. If you still see something bad with them, please ask me infos. I can be wrong at times, but I never want to upset anyone.
Gig
In the year 3000
***

Cakes 45
Posts: 3197


WWW
« Reply #88 on: July 05, 2010, 02:52:04 pm »

Czest3ctf appears available for "double domination" mode... but once I launch the game... I cannot find any "A" or "B" point inside.
Logged

I never want to be aggressive, offending or ironic with my posts. If you find something offending in my posts, read them again searching for a different mood there. If you still see something bad with them, please ask me infos. I can be wrong at times, but I never want to upset anyone.
johnnycage
THIS ONE POST HERE SHOULD DO IT.


Cakes 0
Posts: 1


« Reply #89 on: July 08, 2010, 12:11:34 pm »

Hello, I have installed OA 0.8.1 for 64bit CPU from Debian Testing repository. I downloaded update 0.8.5 from OA webpage, extract to /usr/games/openarena/baseoa. After run the game main menu and screen was blue, so update is ok. But if I change graphics settings in menu, OA crash. This is full message from console (from run the game to crash):
Code:
johnnycage@lenovo:~$ openarena
ioq3+oa 1.35 linux-x86_64 Jun 13 2010
----- FS_Startup -----
Current search path:
/home/johnnycage/.openarena/baseoa
/usr/share/games/openarena/baseoa/pak6-patch085.pk3 (559 files)
/usr/share/games/openarena/baseoa/pak6-misc.pk3 (229 files)
/usr/share/games/openarena/baseoa/pak5-TA.pk3 (139 files)
/usr/share/games/openarena/baseoa/pak4-textures.pk3 (1753 files)
/usr/share/games/openarena/baseoa/pak2-players.pk3 (669 files)
/usr/share/games/openarena/baseoa/pak2-players-mature.pk3 (231 files)
/usr/share/games/openarena/baseoa/pak1-maps.pk3 (100 files)
/usr/share/games/openarena/baseoa/pak0.pk3 (1042 files)
/usr/share/games/openarena/baseoa

----------------------
4722 files in pk3 files
execing default.cfg
execing q3config.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
----- Client Initialization -----
Couldn't read q3history.
----- Initializing Renderer ----
-------------------------------
QKEY found.
----- Client Initialization Complete -----
----- R_Init -----
SDL using driver "x11"
Initializing OpenGL display
Estimated display aspect: 1.779
...setting mode 3: 640 480
Using 8/8/8 Color bits, 24 depth, 8 stencil display.
Available modes: '1366x768 1360x768 720x400 640x350 640x400 640x480 800x600 832x624 1024x768'
GL_RENDERER: Mesa DRI Mobile Intel® GM45 Express Chipset GEM 20091221 2009Q4
Initializing OpenGL extensions
...ignoring GL_EXT_texture_compression_s3tc
...ignoring GL_S3_s3tc
...using GL_EXT_texture_env_add
...using GL_ARB_multitexture
...using GL_EXT_compiled_vertex_array
...ignoring GL_EXT_texture_filter_anisotropic

GL_VENDOR: Tungsten Graphics, Inc
GL_RENDERER: Mesa DRI Mobile Intel® GM45 Express Chipset GEM 20091221 2009Q4
GL_VERSION: 2.1 Mesa 7.7.1
GL_EXTENSIONS: GL_EXT_compiled_vertex_array GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add GL_ARB_copy_buffer GL_ARB_depth_texture GL_ARB_depth_clamp GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_half_float_pixel GL_ARB_map_buffer_range GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_seamless_cube_map GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_shading_language_120 GL_ARB_shadow GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_array_object GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_logic_op GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_cull_vertex GL_EXT_copy_texture GL_EXT_draw_range_elements GL_EXT_framebuffer_blit GL_EXT_framebuffer_object GL_EXT_fog_coord GL_EXT_gpu_program_parameters GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_pixels GL_EXT_pixel_buffer_object GL_EXT_point_parameters GL_EXT_polygon_offset GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_subtexture GL_EXT_texture GL_EXT_texture3D GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_texture_sRGB GL_EXT_texture_swizzle GL_EXT_vertex_array GL_EXT_vertex_array_bgra GL_3DFX_texture_compression_FXT1 GL_APPLE_client_storage GL_APPLE_packed_pixels GL_APPLE_vertex_array_object GL_ATI_blend_equation_separate GL_ATI_envmap_bumpmap GL_ATI_texture_env_combine3 GL_ATI_separate_stencil GL_IBM_multimode_draw_arrays GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_INGR_blend_func_separate GL_MESA_pack_invert GL_MESA_texture_signed_rgba GL_MESA_ycbcr_texture GL_MESA_window_pos GL_NV_blend_square GL_NV_depth_clamp GL_NV_light_max_exponent GL_NV_packed_depth_stencil GL_NV_texture_env_combine4 GL_NV_texture_rectangle GL_NV_texgen_reflection GL_NV_vertex_program GL_NV_vertex_program1_1 GL_OES_read_format GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SUN_multi_draw_arrays GL_S3_s3tc
GL_MAX_TEXTURE_SIZE: 4096
GL_MAX_TEXTURE_UNITS_ARB: 8

PIXELFORMAT: color(24-bits) Z(24-bit) stencil(8-bits)
MODE: 3, 640 x 480 fullscreen hz:N/A
GAMMA: hardware w/ 0 overbright bits
rendering primitives: single glDrawElements
texturemode: GL_LINEAR_MIPMAP_NEAREST
picmip: 1
texture bits: 0
multitexture: enabled
compiled vertex arrays: enabled
texenv add: enabled
compressed textures: disabled
Initializing Shaders
----- finished R_Init -----
------ Initializing Sound ------
Failed to open OpenAL device.
SDL_Init( SDL_INIT_AUDIO )... OK
SDL audio driver is "alsa".
SDL_AudioSpec:
  Format:   AUDIO_S16LSB
  Freq:     22050
  Samples:  705
  Channels: 2
Starting SDL audio callback...
SDL audio initialized.
----- Sound Info -----
    1 stereo
16384 samples
   16 samplebits
    1 submission_chunk
22050 speed
0x2a979a0 dma buffer
No background file.
----------------------
Sound initialization successful.
--------------------------------
Sound memory manager started
Loading vm file vm/ui.qvm...
...which has vmMagic VM_MAGIC_VER2
Loading 1550 jump table targets
total 0, hsize 1021, zero 1021, min 0, max 0
total 10042, hsize 1021, zero 2, min 0, max 30
VM file ui compiled to 3203472 bytes of code (0x7f263c17d000 - 0x7f263c48b190)
compilation took 1.589022 seconds
ui loaded in 1450816 bytes on the hunk
51 arenas parsed
1 arenas ignored to make count divisible by 4
24 bots parsed
^3WARNING: unknown blend mode 'gl_one_minus_dst_color' in shader 'menuback_blueish', substituting GL_ONE
--- Common Initialization Complete ---
IP: 127.0.0.1
IP: 192.168.212.115
IP: 10.0.0.60
IP6: ::1
IP6: fe80::221:ff:fef7:a033%eth1
Opening IP6 socket: [::]:27960
Opening IP socket: 0.0.0.0:27960
RE_Shutdown( 1 )
Received signal 11, exiting...
----- CL_Shutdown -----
Closing SDL audio device...
SDL audio device shut down.
RE_Shutdown( 1 )
*** glibc detected *** openarena: malloc(): smallbin double linked list corrupted: 0x0000000002642ad0 ***
======= Backtrace: =========
/lib/libc.so.6(+0x71b16)[0x7f2650890b16]
/lib/libc.so.6(+0x7542d)[0x7f265089442d]
/lib/libc.so.6(__libc_malloc+0x70)[0x7f2650895970]
/usr/lib/libX11.so.6(+0x4d08b)[0x7f264f72e08b]
/usr/lib/libX11.so.6(+0x4dc5e)[0x7f264f72ec5e]
/usr/lib/libX11.so.6(XrmGetFileDatabase+0x55)[0x7f264f72f135]
/usr/lib/libX11.so.6(XGetErrorDatabaseText+0x1c1)[0x7f264f706d01]
/usr/lib/libX11.so.6(XGetErrorText+0x153)[0x7f264f706ee3]
/usr/lib/libX11.so.6(+0x4767d)[0x7f264f72867d]
/usr/lib/libX11.so.6(_XDefaultError+0x13)[0x7f264f728c23]
/usr/lib/libX11.so.6(_XError+0xcc)[0x7f264f728d0c]
/usr/lib/libX11.so.6(+0x4f139)[0x7f264f730139]
/usr/lib/libX11.so.6(_XReply+0x140)[0x7f264f730820]
/usr/lib/libX11.so.6(XSync+0x63)[0x7f264f724403]
/usr/lib/libX11.so.6(XCloseDisplay+0x80)[0x7f264f702e70]
/usr/lib/libSDL-1.2.so.0(+0x3f2ec)[0x7f26523df2ec]
/usr/lib/libSDL-1.2.so.0(SDL_VideoQuit+0x42)[0x7f26523d0492]
/usr/lib/libSDL-1.2.so.0(SDL_QuitSubSystem+0x45)[0x7f26523a8dc5]
openarena[0x56b8a3]
openarena[0x53c895]
openarena[0x423fbe]
openarena[0x56498a]
/lib/libc.so.6(+0x321f0)[0x7f26508511f0]
[0x7f263e334d20]
======= Memory map: ========
00400000-005a0000 r-xp 00000000 08:01 572                                /usr/games/openarena
007a0000-007a7000 rw-p 001a0000 08:01 572                                /usr/games/openarena
007a7000-02179000 rw-p 00000000 00:00 0
02625000-02ee8000 rw-p 00000000 00:00 0                                  [heap]
7f2634000000-7f2634021000 rw-p 00000000 00:00 0
7f2634021000-7f2638000000 ---p 00000000 00:00 0
7f2638a8d000-7f2638aa3000 r-xp 00000000 08:01 15478                      /lib/libgcc_s.so.1
7f2638aa3000-7f2638ca2000 ---p 00016000 08:01 15478                      /lib/libgcc_s.so.1
7f2638ca2000-7f2638ca3000 rw-p 00015000 08:01 15478                      /lib/libgcc_s.so.1
7f2638cba000-7f2638cbb000 ---p 00000000 00:00 0
7f2638cbb000-7f26394bb000 rw-p 00000000 00:00 0
7f26394bb000-7f26394bc000 ---p 00000000 00:00 0
7f26394bc000-7f2639cbc000 rw-p 00000000 00:00 0
7f263c48c000-7f263dcbd000 rw-p 00000000 00:00 0
7f263dcbd000-7f263dcbe000 ---p 00000000 00:00 0
7f263dcbe000-7f263e4be000 rw-p 00000000 00:00 0
7f263e4ec000-7f263e52c000 rw-s 15118a000 00:05 3439                      /dev/dri/card0
7f263e54f000-7f263e553000 r-xp 00000000 08:01 3432                       /lib/libattr.so.1.1.0
7f263e553000-7f263e752000 ---p 00004000 08:01 3432                       /lib/libattr.so.1.1.0
7f263e752000-7f263e753000 rw-p 00003000 08:01 3432                       /lib/libattr.so.1.1.0
7f263e753000-7f263ea06000 r-xp 00000000 08:01 32290                      /usr/lib/libvorbisenc.so.2.0.7
7f263ea06000-7f263ec05000 ---p 002b3000 08:01 32290                      /usr/lib/libvorbisenc.so.2.0.7
7f263ec05000-7f263ec21000 rw-p 002b2000 08:01 32290                      /usr/lib/libvorbisenc.so.2.0.7
7f263ec21000-7f263ec6a000 r-xp 00000000 08:01 38754                      /usr/lib/libFLAC.so.8.2.0
7f263ec6a000-7f263ee6a000 ---p 00049000 08:01 38754                      /usr/lib/libFLAC.so.8.2.0
7f263ee6a000-7f263ee6c000 rw-p 00049000 08:01 38754                      /usr/lib/libFLAC.so.8.2.0
7f263ee6c000-7f263ee7b000 r-xp 00000000 08:01 16958                      /usr/lib/libXi.so.6.1.0
7f263ee7b000-7f263f07a000 ---p 0000f000 08:01 16958                      /usr/lib/libXi.so.6.1.0
7f263f07a000-7f263f07b000 rw-p 0000e000 08:01 16958                      /usr/lib/libXi.so.6.1.0
7f263f07b000-7f263f07f000 r-xp 00000000 08:01 321                        /lib/libuuid.so.1.3.0
7f263f07f000-7f263f27e000 ---p 00004000 08:01 321                        /lib/libuuid.so.1.3.0
7f263f27e000-7f263f27f000 rw-p 00003000 08:01 321                        /lib/libuuid.so.1.3.0
7f263f27f000-7f263f283000 r-xp 00000000 08:01 38737                      /lib/libcap.so.2.17
7f263f283000-7f263f482000 ---p 00004000 08:01 38737                      /lib/libcap.so.2.17
7f263f482000-7f263f483000 rw-p 00003000 08:01 38737                      /lib/libcap.so.2.17
7f263f483000-7f263f488000 r-xp 00000000 08:01 3772                       /usr/lib/libgdbm.so.3.0.0
7f263f488000-7f263f688000 ---p 00005000 08:01 3772                       /usr/lib/libgdbm.so.3.0.0
7f263f688000-7f263f689000 rw-p 00005000 08:01 3772                       /usr/lib/libgdbm.so.3.0.0
7f263f689000-7f263f6c7000 r-xp 00000000 08:01 15269                      /lib/libdbus-1.so.3.4.0
7f263f6c7000-7f263f8c7000 ---p 0003e000 08:01 15269                      /lib/libdbus-1.so.3.4.0
7f263f8c7000-7f263f8c8000 r--p 0003e000 08:01 15269                      /lib/libdbus-1.so.3.4.0
7f263f8c8000-7f263f8c9000 rw-p 0003f000 08:01 15269                      /lib/libdbus-1.so.3.4.0
7f263f8c9000-7f263f8cd000 r-xp 00000000 08:01 38727                      /usr/lib/libasyncns.so.0.1.0
7f263f8cd000-7f263facc000 ---p 00004000 08:01 38727                      /usr/lib/libasyncns.so.0.1.0
7f263facc000-7f263facd000 rw-p 00003000 08:01 38727                      /usr/lib/libasyncns.so.0.1.0
7f263facd000-7f263fb2b000 r-xp 00000000 08:01 38791                      /usr/lib/libsndfile.so.1.0.21
7f263fb2b000-7f263fd2b000 ---p 0005e000 08:01 38791                      /usr/lib/libsndfile.so.1.0.21
7f263fd2b000-7f263fd2e000 rw-p 0005e000 08:01 38791                      /usr/lib/libsndfile.so.1.0.21
7f263fd2e000-7f263fd32000 rw-p 00000000 00:00 0
7f263fd32000-7f263fd3a000 r-xp 00000000 08:01 855                        /lib/libwrap.so.0.7.6
7f263fd3a000-7f263ff39000 ---p 00008000 08:01 855                        /lib/libwrap.so.0.7.6
7f263ff39000-7f263ff3b000 rw-p 00007000 08:01 855                        /lib/libwrap.so.0.7.6
7f263ff3b000-7f263ff40000 r-xp 00000000 08:01 18828                      /usr/lib/libXtst.so.6.1.0
7f263ff40000-7f2640140000 ---p 00005000 08:01 18828                      /usr/lib/libXtst.so.6.1.0
7f2640140000-7f2640141000 rw-p 00005000 08:01 18828                      /usr/lib/libXtst.so.6.1.0
7f2640141000-7f2640149000 r-xp 00000000 08:01 18763                      /usr/lib/libSM.so.6.0.1
7f2640149000-7f2640348000 ---p 00008000 08:01 18763                      /usr/lib/libSM.so.6.0.1
7f2640348000-7f2640349000 rw-p 00007000 08:01 18763                      /usr/lib/libSM.so.6.0.1
7f2640349000-7f2640360000 r-xp 00000000 08:01 18757                      /usr/lib/libICE.so.6.3.0
7f2640360000-7f264055f000 ---p 00017000 08:01 18757                      /usr/lib/libICE.so.6.3.0
7f264055f000-7f2640561000 rw-p 00016000 08:01 18757                      /usr/lib/libICE.so.6.3.0DOUBLE SIGNAL FAULT: Received signal 6, exiting...
Neoprávněný přístup do paměti (SIGSEGV)

Logged

OS: Debian Testing 64bit, Kernel 2.6.32, GNOME 2.30.0
NB: Lenovo G550, Intel Pentium Dual-Core T4200 2.0GHz, RAM 3GB, WD 320GB, Intel GMA X4500 256MB
brettalton
Nub


Cakes 2
Posts: 18


fly into the light of the dark black night


WWW
« Reply #90 on: July 08, 2010, 02:27:20 pm »

I may have a PulseAudio problem in Ubuntu 10.04: http://openarena.ws/board/index.php?topic=3833.0
Logged

brettalton
Nub


Cakes 2
Posts: 18


fly into the light of the dark black night


WWW
« Reply #91 on: July 08, 2010, 02:45:06 pm »

I also have a really weird error where I try and play single player, but no bots appear, only me. It's not a skirmish, it's the actual single player.
Logged

Cacatoes
Banned for leasing own account
Posts a lot
*

Cakes 65
Posts: 1429


also banned for baiting another to violate rules


« Reply #92 on: July 09, 2010, 05:43:10 am »

You may consider using the oa.ws release, people seem to experience problems with Debian ones. Eventually check their bug reports.

About the bots, there may be error messages printed in the OA console.
Logged

Todo: Walk the cat.
Gig
In the year 3000
***

Cakes 45
Posts: 3197


WWW
« Reply #93 on: July 13, 2010, 03:34:59 am »

Little bug with text color handling.
As you can see here, text color ^8 is shown as orange in the score table (and in the "Player settings" menu and in the extended "message of the day"), but is shown as black in the console.
« Last Edit: October 23, 2010, 05:01:42 am by Gig » Logged

I never want to be aggressive, offending or ironic with my posts. If you find something offending in my posts, read them again searching for a different mood there. If you still see something bad with them, please ask me infos. I can be wrong at times, but I never want to upset anyone.
Gig
In the year 3000
***

Cakes 45
Posts: 3197


WWW
« Reply #94 on: August 17, 2010, 04:21:58 pm »

Hi guys! Did someone take a look the the text color ^8 code in the console (see the previous post)?

I want to point out another problem (I wrote about it here, and I noticed it on this thread): now you get no error message at all when you try to pass the limit of the 16 favorite servers, simply the new server will not be added to the list.

Another thing: there is a bug with the "hide private" function: when you enter the "multiplayer" menu, you find it "on", even if the last time you set it "off".

Talking about "multiplayer" menu, I suggest an improvement to the server browser interface: to show somewhere the server address (I suggest in the line below "hit refresh to update"), when you select one. I suppose it should not be too difficult to do, and it may be useful.

« Last Edit: August 17, 2010, 04:32:42 pm by Gig » Logged

I never want to be aggressive, offending or ironic with my posts. If you find something offending in my posts, read them again searching for a different mood there. If you still see something bad with them, please ask me infos. I can be wrong at times, but I never want to upset anyone.
Gig
In the year 3000
***

Cakes 45
Posts: 3197


WWW
« Reply #95 on: September 15, 2010, 09:36:47 am »

Problem pointed out by Falkland: Fog density is different than Quake 3, sometimes preventing to view also characters with brightskins. Dedicated topic here.
Logged

I never want to be aggressive, offending or ironic with my posts. If you find something offending in my posts, read them again searching for a different mood there. If you still see something bad with them, please ask me infos. I can be wrong at times, but I never want to upset anyone.
Gig
In the year 3000
***

Cakes 45
Posts: 3197


WWW
« Reply #96 on: September 16, 2010, 03:38:42 pm »

Another bug found (and quite worrying):
When you are playing on Team Deathmatch mode (g_gametype 3), are currently fighting and then you select Esc --> Start --> Spectate... your player suicides and you enter spectator mode... and your team scores a point! Since going to spectate "suicides" your character (not to be confused with "kill" command, that seems not affected by the bug), it is expected that your team loses a point, or at least to not influence score... gaining score for leaving the team has no sense. Same thing if you directly switch from a team to the other: your old team will gain a frag!

Original Q3A (tested v 1.32c) seems to not suffer this bug.
I don't know if other team-based gametypes suffer of the same bug, but probably not because I suppose TDM is the only team-based gametype that checks for fraglimit instead of capturelimit, right?

Example: if you are using bot_minplayers feature, you are in the red team and the team score is 0, then select "spectate", red team score becomes 1 and a bot enters at your place; if you join again the red team, a red bot is kicked, and your team score goes to 2... without having fragged a single enemy!
This bug can be used like a cheat!

PS: I noticed this while doing some tests to update the "Manual/Spectate" page on the Wiki. I removed an old bug warning there (that was found in OA 0.6) and that seems resolved; anyway, choosing "Esc --> Start --> Spectate" while you are already spectating in Tournament mode, still moves you to the bottom of the queue (Q3 does this, too): I don't know if it is a bug or not, however you need no more to use the menu to switch from "follow" to "free" spectate mode (you can simply press "use_item" key, instead), thus you can avoid the problem.
« Last Edit: September 16, 2010, 05:02:39 pm by Gig » Logged

I never want to be aggressive, offending or ironic with my posts. If you find something offending in my posts, read them again searching for a different mood there. If you still see something bad with them, please ask me infos. I can be wrong at times, but I never want to upset anyone.
sago007
Posts a lot
*

Cakes 51
Posts: 1482


Open Arena Modder/Player


WWW
« Reply #97 on: September 17, 2010, 07:39:15 am »

Annoying bug.
Logged

There are nothing offending in my posts. See http://www.wired.com/news/technology/0,70179-0.html for details
Gig
In the year 3000
***

Cakes 45
Posts: 3197


WWW
« Reply #98 on: September 21, 2010, 04:32:38 pm »

Update: the score bug when changing team in TDM mode seems fixed in OAX Beta 47.
Logged

I never want to be aggressive, offending or ironic with my posts. If you find something offending in my posts, read them again searching for a different mood there. If you still see something bad with them, please ask me infos. I can be wrong at times, but I never want to upset anyone.
Gig
In the year 3000
***

Cakes 45
Posts: 3197


WWW
« Reply #99 on: September 26, 2010, 06:11:07 am »

Another problem related with bloom. If I have "bloom" enabled, and I set the texture quality to 16 bits, some sort of semi-transparent square appears on the bottom left corner of the screen... and the framerate drastically goes down. Does this happen only for me?

Another problem (this one not related with bloom, I suppose). It seems that (with cg_oldrail 0), when you shoot with the railgun aiming to a very far object, the inner trace is not drawn. When aiming at other distances (still very far), the inner trace is not drawn and the outer spiral "begins" far, far away from you (unless you use zoom, it is difficult to see the spiral).
To try, go to wrackdm17, take the railgun and begin shooting at the opposite "invisible wall" of the map, at various heights...

Update: About the railgun bug, it comes from the original Q3A, and I just opened a bug (4774) on the ioquake 3 "bugzilla" site... http://bugzilla.icculus.org/show_bug.cgi?id=4774
Update2: it seems somehow related to the fact that the railgun range is shorter than the machinegun range. Please take a look to this thread!

A question: "bloom" feature is from ioquake3 or original from OpenArena? r_bloom seems to not exist under ioquake3...
« Last Edit: November 06, 2011, 05:18:01 am by Gig » Logged

I never want to be aggressive, offending or ironic with my posts. If you find something offending in my posts, read them again searching for a different mood there. If you still see something bad with them, please ask me infos. I can be wrong at times, but I never want to upset anyone.
Pages: 1 2 3 [4] 5 6 ... 11
  Print  
 
Jump to: