Pages: [1]
  Print  
Author Topic: Open Arena Dedicated Debian linux  (Read 3729 times)
beastofrock
THIS ONE POST HERE SHOULD DO IT.


Cakes 0
Posts: 1


« on: October 18, 2010, 12:37:47 AM »

I got 2 problems on my dedicated Server:
1. I Downloaded some Models to the Server, but they are not downloaded to the clients. In my config I configured downloads on and configured the right basedir, but it still doesn´t work. I tried the download by deleting the pak03.pk3-file on the client and it startet to download it from my server, very slow, but it did. Whats wrong?

2. In my System I only have 128MB Ram, so I have to reduce the hunkmegs to 64 or 32, I have to modify the q3config for that. It doesn´t work if i just write it to my own config.
Logged
Cacatoes
Banned for leasing own account
Posts a lot
*

Cakes 73
Posts: 1427


also banned for baiting another to violate rules


« Reply #1 on: October 18, 2010, 03:02:23 AM »

Hi,

1) I think I had a similar problem, models were randomly downloaded, or if there were bots on the server using these models, only these ones were downloaded. Been some time I didn't try.

2) ~.openarena/baseoa/q3config.cfg is your config file, right ? At least on my setup there is no other .cfg file (so which one do you modify ?). Most of the time I saw com_hunkmegs used it was as a command line parameter, maybe if it's in your config file it doesn't get read at startup, I can't affirm it's a normal behaviour but I'd expect it.

Sorry, no real answer to bring, only confirmation of your doubts hehe.

Welcome on the board.
Logged

Todo: Walk the cat.
Gig
In the year 3000
***

Cakes 45
Posts: 4378


WWW
« Reply #2 on: October 18, 2010, 03:48:22 AM »

I don't know exactly how the engine chooses the files to autodownload. It downloads the pk3 of a certain map only when you have to play on that map... thus, I suppose that it downloads the pk3 of a model only when in the server there is someone (a human or a bot) that is effectively using that model. I repeat, I suppose. Maybe you may try to connect to that server (that you know holds that specific model) and use the /model comand to select it, even if you do not have it in your client: I have not idea if this will trigger the download process or not.

About the slow download speed, the speed is limited to the \rate (client-side) and \sv_maxrate (server-side) values. Since the maximum, AFAIK, is 25000, it means that the maximum download speed is about 20-25 KB/s. To get higher download speeds, one has to use "www downloading", copying the needed files into an HTTP or FTP public web space, that will accessed by the client at much higher speeds. Take a look to here.
Logged

I never want to be aggressive, offensive or ironic with my posts. If you find something offending in my posts, read them again searching for a different mood there. If you still see something bad with them, please ask me infos. I can be wrong at times, but I never want to upset anyone.
Pages: [1]
  Print  
 
Jump to: