Pages: 1 [2]
  Print  
Author Topic: My server is getting bot striked...  (Read 51755 times)
WaspKiller
Bigger member


Cakes 8
Posts: 159



WWW
« Reply #25 on: December 11, 2011, 05:51:06 AM »

This has me wondering why a developer was posting firewall rules on the E+ forum 3 weeks ago when the flood protection has been in the server code for almost 2 years? /me confused.


Then let me clear up your confusion. 


Quote from: ioquake3 log
Revision: 1762
Time: 03.01.2010 23:12
Author: tma
Path: code/server/sv_main.c (trunk)
Message: * Rate limit getstatus and rcon connectionless requests
...


What Grey Matter was referring to only applies to OpenArena (and its Mods).  The E+ Dev you are referring to and players at ExcessivePlus.net are all Q3 users, they are using the official id 1.32c client not ioq3.  I only re-posted his suggestion as it was relevant at the time.

E+ for OA has its own web site and separate Mod.
Logged



Calm is for LOSERS!  ANGER fuels my game and btw you're NEXT!
7
Member


Cakes 7
Posts: 278


Is 7 up?


« Reply #26 on: December 11, 2011, 07:03:34 AM »

they are using the official id 1.32c client not ioq3

Yeah, I didn't realize that, I wonder how they keep up with all the security holes (5 unpatched holes dating back from 2006 doesn't spell any good). I wasn't accusing anybody of anything, just wondering Wink
Logged

I'm on the ten most wanted list, I've got it dead in the groove.
My face is on every wanted poster in town, for the way I move.
grey matter
Member


Cakes 8
Posts: 381

>9k


« Reply #27 on: December 11, 2011, 07:14:56 AM »

I'll be a little pedantic here;

The code in question is part of the server, not the client. Furthermore it is part of the engine, not the gamecode.

That means that any mod (OpenArena, World of Padman, Urban Terror, Smokin' Guns, Tremulous, ..) which uses an up-to-date ioquake3 fork or even just plain ioq3ded already has the code fix. The only reason why you might not want to use ioq3ded on your server is the buggy PunkBuster.
The difficulty here is getting recent binaries, if one does not or can not compile them on his own. That's the problem of everyone maintaining his own fork with little to no advantages over vanilla ioquake3.

@Gig
Both the code-wise fix as well as using iptables can of course not prevent the packets from being sent by the attacker and thus using up your incoming bandwith. The problem itself is a problem with the Quake 3 network protocol, which can not be properly fixed without breaking backwards compability with older Quake 3 clients. This includes players as well as serverbrowsers, administrations bots like B3 etc.

Logged

This space is for rent.
MilanFIN
Nub


Cakes 1
Posts: 41


WWW
« Reply #28 on: December 11, 2011, 01:38:16 PM »

Is it just enough if I update the ioquake3 engine?
Where can I get it then and how to install it?
Can all of the players using the 085 versio of OA play on my server then?
Logged

http://arenafinland.tk a finnish OpenArena server and clan.
Gig
In the year 3000
***

Cakes 45
Posts: 4382


WWW
« Reply #29 on: December 11, 2011, 06:23:20 PM »

Wait... where are you using the E+ mod exactly?
- Original Q3
- ioquake3
- OpenArena

If it is the third case then yes, you should be able to download and use version 25 OA executables on your server, and OA 085 clients should be able to play on it.
Logged

I never want to be aggressive, offensive or ironic with my posts. If you find something offending in my posts, read them again searching for a different mood there. If you still see something bad with them, please ask me infos. I can be wrong at times, but I never want to upset anyone.
MilanFIN
Nub


Cakes 1
Posts: 41


WWW
« Reply #30 on: December 13, 2011, 01:29:53 AM »

NO
just clean openarena 0.8.5... where did you invent I'm using E+?
Where can I get the new ioquake3 and DOES it cause any difference to the gameplay for the clients using 085 versio of oa?
Logged

http://arenafinland.tk a finnish OpenArena server and clan.
7
Member


Cakes 7
Posts: 278


Is 7 up?


« Reply #31 on: December 13, 2011, 01:59:31 AM »

You should download the newest OA binaries, not the ioquake3 ones, you'll have to do a lot of reconfiguring if you use the ioquake3 binaries. If you use the OA ones it's a matter of copying the oa_ded executable to your server, restarting the OA server, and you're good to go. It's compatible with 0.8.5.

We're on engine v26 now, you can find a download link here:
http://openarena.ws/board/index.php?topic=1933.msg41854#msg41854
Logged

I'm on the ten most wanted list, I've got it dead in the groove.
My face is on every wanted poster in town, for the way I move.
Pages: 1 [2]
  Print  
 
Jump to: