Pages: [1]
  Print  
Author Topic: Error: sv_setbrushmodel:NULL [Solved]  (Read 11157 times)
Peter Silie
Member


Cakes 2008
Posts: 610



« on: January 24, 2012, 02:41:19 PM »

Mapping is always some kind of a riddle.
You make a new map and try to compile it. Sometimes all works fine on the 1st run, but as soon as you try to test your map inside of OA you get an error - like in the case above while loading the map.

Solution is very simple:
http://padworld.myexp.de/forum/viewtopic.php?f=10&t=3302

Enter the entity list (press "L") and search for a trigger entity without trianlge.
Select the entity and press "backspace" to delete the entity from the map.

You can also try to run the "brush cleanup" or select the whole map and save the selected map (save seleted...) inside a new file (like mentioned here: http://www.katsbits.com/tutorials/idtech/q3map2-error-messages.php?subaction=showfull&id=1149147724&archive=&start_from=&ucat=15&), but the above solution worked much better! Cheesy
Logged
Neon_Knight
In the year 3000
***

Cakes 49
Posts: 3763


Trickster God.


« Reply #1 on: January 24, 2012, 04:37:23 PM »

This also happens with the func_* entities.
While working on oa_bases7 I ran into this problem because, somehow, the platforms were vanished. By recreating them and deleting the old empty func_plat entities. I've managed to solve it. In other maps, this happened with the func_group entity.

The best way to prevent it is to ungroup the entity, do the brushwork tweak, and regroup. OFC, sadly, this means that the properties will be gone.
Logged


"Detailed" is nice, but if it gets in the way of clarity, it ceases being a nice addition and becomes a problem. - TVT
Want to contribute? Read this.
Pages: [1]
  Print  
 
Jump to: