Pages: [1]
  Print  
Author Topic: backwards compatibility hiccup  (Read 5931 times)
dmn_clown
Posts a lot
*

Cakes 1
Posts: 1324


« on: January 30, 2007, 06:48:25 AM »

There is a hiccup in backwards compatibility, the majority of iD's maps seem to work, however q3ctf2 crashes the engine every time.

Code:
------------ Map Loading ------------
trying to load maps/q3ctf2.aas
loaded maps/q3ctf2.aas
found 99 level items
-------------------------------------
11 bots parsed
42 arenas parsed
AAS initialized.
-----------------------------------
RE_Shutdown( 0 )
----- R_Init -----

[useless crap]

----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
----- Server Shutdown (Server fatal crashed: Requested feature was omitted at compile time
) -----
==== ShutdownGame ====
AAS shutdown.
Closed log botlib.log
---------------------------
Sys_Error: Requested feature was omitted at compile time


so the question should be which feature does q3ctf2 have that none of the working maps have?
Logged

tw3k
Lesser Nub


Cakes 0
Posts: 143



« Reply #1 on: January 30, 2007, 08:52:02 AM »

idk, maybe it has to do with [useless crap] Wink
Logged
dmn_clown
Posts a lot
*

Cakes 1
Posts: 1324


« Reply #2 on: January 30, 2007, 12:31:26 PM »

HA!

Nope.  It is something in q3ctf2, q3dm8, and q3dm11 all result in the given error _ONLY_ in oa.  In other words there is nothing wrong with my video driver, nothing listed as fatal in all of the missing textures and wav files, and the assembler runs properly (Hence their removal from the initial post).

Logged

Neological
Nub


Cakes 0
Posts: 10


« Reply #3 on: January 30, 2007, 02:56:46 PM »

I think it has to do something with the textures. Since I own Q3A Retail, I decided to do some testing myself on this. What I discovered was weird. I managed to narrow down the problem of Q3CTF2 to the textures. I also took a look at what textures it was trying. Some of the textures it was trying to use didn't even exist in the Q3A PAK0 file. Like the following:

trying textures/base_light/light1blue_2000.TGA...
trying textures/base_light/ceil_white5k.TGA...
trying textures/base_light/light1red_2000.TGA...

By narrowing it down, I managed to get it working with some of the JPEG textures within the "base_light" texture directory. I haven't quite narrowed it down yet because I'm doing this all manually. (If you need a reason for this, I just needed a challenge to get rid of boredom.)

Here's the list of textures that I narrowed it down to.

ceil1_38.blend.jpg
ceil1_38.jpg
light1blue.blend.jpg
light1blue.jpg
light1red.blend.jpg
light1red.jpg

Now, this also works with Q3DM8, but not Q3DM11. I still need to figure out Q3DM11. This should help you out a little bit for those two maps. I'll update this post or make a new one if someone posts whichever comes first.

[Edit]
Update! I found the two textures causing problems in Q3DM11. When I was having problems, I made a wild guess and said it had to do something with base_light textures and found out that was it. Kinda an annoyance.

ceil1_38.blend.jpg
ceil1_38.jpg
jaildr1_3.blend.jpg
jaildr1_3.jpg

Enjoy yourself.
« Last Edit: January 30, 2007, 03:46:23 PM by Neological » Logged
dmn_clown
Posts a lot
*

Cakes 1
Posts: 1324


« Reply #4 on: January 30, 2007, 04:35:23 PM »

light1blue.blend.jpg
light1blue.jpg
light1red.blend.jpg
light1red.jpg

Now, this also works with Q3DM8, but not Q3DM11. I still need to figure out Q3DM11. This should help you out a little bit for those two maps. I'll update this post or make a new one if someone posts whichever comes first.

[Edit]
Update! I found the two textures causing problems in Q3DM11. When I was having problems, I made a wild guess and said it had to do something with base_light textures and found out that was it. Kinda an annoyance.

ceil1_38.blend.jpg
ceil1_38.jpg
jaildr1_3.blend.jpg
jaildr1_3.jpg

Enjoy yourself.

Close... on a hunch I went in and removed two textures from oa's pak4 ceil1_39.jpg and light1.blend.jpg both are progressive jpegs which will bring the engine crashing down.  ceil1_39.jpg should be removed from the svn *cough* leileilol *cough* as there is a ceil1_39.tga and here is a converted light1.blend.jpg (Baseline of course). 

Thanks for pushing me in the right direction, Neological,  now its a bit easier to see what textures and shaders need to be done.
Logged

fromhell
Administrator
GET A LIFE!
**********

Cakes 35
Posts: 14519



WWW
« Reply #5 on: January 30, 2007, 11:15:42 PM »

that "feature" error is just progressive encoding on JPEGS not being supported.
Logged

asking when OA3 will be done won't get OA3 done.
Progress of OA3 currently occurs behind closed doors alone

I do not provide technical support either.

new code development on github
dmn_clown
Posts a lot
*

Cakes 1
Posts: 1324


« Reply #6 on: January 31, 2007, 02:23:59 PM »

I know that...








(now)
Logged

Pages: [1]
  Print  
 
Jump to: