Pages: [1]
  Print  
Author Topic: uintptr_t error  (Read 2755 times)
RC4-GaryOakPhD
Ok i've posted twice!


Cakes 0
Posts: 2


« on: May 17, 2014, 06:17:07 pm »

I'm trying to compile on a 32 bit debian 6 box, but I get this error when compiling the engine:

Code:
In file included from code/SDL12/include/SDL_config.h:42,
                 from code/SDL12/include/SDL_stdinc.h:30,
                 from code/SDL12/include/SDL_main.h:26,
                 from code/SDL12/include/SDL.h:30,
                 from code/client/../sys/sys_loadlib.h:39,
                 from code/client/qal.c:32:
code/SDL12/include/SDL_config_minimal.h:39: error: conflicting types for 'uintptr_t'
/usr/include/stdint.h:129: note: previous declaration of 'uintptr_t' was here
make[2]: *** [build/release-linux-i386/client/qal.o] Error 1
make[2]: Leaving directory `/root/openarena/openarena'
make[1]: *** [targets] Error 2
make[1]: Leaving directory `/root/openarena/openarena'
make: *** [release] Error 2
Logged
andrewj
Member


Cakes 23
Posts: 571



« Reply #1 on: May 18, 2014, 01:49:08 am »

A quick fix may be to edit the "code/SDL12/include/SDL_config_minimal.h" file and on line 39, where uintptr is declared, replace "long" with "int".

A better fix is probably to install the "libsdl1.2-dev" package and get the Makefile to use it -- I can't remember exactly what is needed, perhaps nothing.
Logged
RC4-GaryOakPhD
Ok i've posted twice!


Cakes 0
Posts: 2


« Reply #2 on: May 18, 2014, 06:31:07 am »

A quick fix may be to edit the "code/SDL12/include/SDL_config_minimal.h" file and on line 39, where uintptr is declared, replace "long" with "int".

A better fix is probably to install the "libsdl1.2-dev" package and get the Makefile to use it -- I can't remember exactly what is needed, perhaps nothing.
Alright, I've done that. Now look Tongue
http://pastebin.com/zUFN4wuL
Logged
grey matter
Member


Cakes 8
Posts: 381

>9k


« Reply #3 on: May 18, 2014, 10:17:40 am »

Code:
$ make USE_LOCAL_HEADERS=0
This will cause the build to use system headers instead of those in code/. You might need to install some more *-dev packages or just disable the related USE_* make variables (see README).
Logged

This space is for rent.
Pages: [1]
  Print  
 
Jump to: