Pages: [1]
Author Topic: Controling dedicated server?  (Read 11452 times)

Cakes -1
Posts: 229

« on: March 31, 2007, 06:00:39 AM »


I am running a (SUPER HARDCORE FAST 1MBIT) server, and its dedicated. The thing is, how the heck do I control it?

I have tried starting the game through a shell, and then setting up a dedicated server, but all I can do is (in a weird way) print messages to the game, I want to be able to enter commands.

Anyone know how I can do this? (Can it be done remotely?)


(PS. I am running on a Mac, so there are no dedicated binaries.)
« Reply #1 on: March 31, 2007, 11:42:48 AM »

I think it'd be awesome if you could control a server through a shell via ssh, but the way it's done is rcon (remote console, I guess).

Basically you need to set an rconpassword in your server config, then when you're connected to the server do "\rconpassword yourpassword" and then any command you want to execute on the server needs to follow "\rcon" (eg, "\rcon map_restart").

I may be an ignorant fool, but don't you use the Linux binaries for the Mac version?

Cakes -1
Posts: 229

« Reply #2 on: March 31, 2007, 04:52:12 PM »

ah thanks for that. i'll have some good kicking action now!

no, the mac version doesnt come with any binaries, i just get it running through the 'create server' option.
« Last Edit: March 31, 2007, 04:54:28 PM by kick52 » Logged
more like blank dumb
Lesser Nub

Cakes 0
Posts: 135

« Reply #3 on: March 31, 2007, 07:04:57 PM »

You could run it from the terminal:

ioquake3.ppc +set dedicated 2

Or whatever the file is called, read the server wiki page.

Cakes 0
Posts: 5

« Reply #4 on: April 04, 2007, 04:58:52 AM »

I seted up choyaserver.cfg like this:

sv_hostname "^2C^5hoya^12^5oft ^12^5erver"
sv_maxclients 12
sv_master1 ""
rconpassword "mypassword"

my running script:

./ioq3ded.i386 +exec choyaserver.cfg +set dedicated 2 +set net_port 27960 +map aggressor

hm... when I execute the rcon command the game says: rcon password is not seted in this server (lol?)
I tried to execute rconpassword mypassword and the rconaddress, but nothing happens, always says not seted.

what's wrong? :O

EDIT: I Solved this adding +set rconpassword mypassword at the running script (hmm, not in the server config :S :S)
« Last Edit: April 04, 2007, 05:02:42 AM by Choyano » Logged
Pages: [1]
Jump to: