Pages: [1]
  Print  
Author Topic: Can't find map map/MyTest.bsp  (Read 8272 times)
Dave
Nub


Cakes 0
Posts: 29


« on: November 29, 2007, 11:54:06 AM »

I've created my first map.  Just a hollow box with a single light, spawn point, and textured walls.  After compiling it, Open Arena kept saying it couldn't find MyTest.bsp.  I moved stuff around and recompiled it and then I could load it.  I added some guns, more light and a quad and now I'm back to the same problem.  The BSP file exist and is around 105k in size, GTKRadiant isnt' spitting leak errors or anything like that, but Open Arena said it cannot find the MyTest.bsp file when attempting to load the map.

Can anyone point me in the first direction?

Thanks,
Dave
Logged
Ylle
Nub


Cakes 0
Posts: 25

Member


« Reply #1 on: November 29, 2007, 12:01:21 PM »

Go to the console and type in
sv_pure 0

then try reloading it.
Logged
Dave
Nub


Cakes 0
Posts: 29


« Reply #2 on: November 29, 2007, 12:10:00 PM »

Go to the console and type in
sv_pure 0

then try reloading it.

I'm sorry, I did that.   I run the following, and get the error:

/sv_pure 0
/devmap MyTest
Can't find map map/MyTest.bsp

The map is located in Open Arena\baseoa\maps\MyTest.bsp

EDIT: Odd thing is, I finally got it to load again, and it was missing all the extra stuff I had added.  (quad, weapon, extra light)  This was after I recompiled it at least 20 times.
« Last Edit: November 29, 2007, 12:18:12 PM by Dave » Logged
kit89
Member


Cakes 6
Posts: 636


Shoot him..


« Reply #3 on: November 29, 2007, 12:30:18 PM »

Delete the MyTest.bsp from the map folder

And then recompile. Make sure its in the maps directory and run it in OpenArena.

Also I suggest you setup a .pk3 file for your map.
Logged
Dave
Nub


Cakes 0
Posts: 29


« Reply #4 on: November 29, 2007, 01:04:34 PM »

I run the following compile using a batch file (got it from GTKRadiant's build menu because I wanted to watch the output for errors because of my problems)

CMD: comp.bat MyTest

del "%1.bsp"
del "%1.prt"
del "%1.srf"
q3map2 -meta "%1.map"
q3map2 -vis -saveprt -fast "%1.map"
q3map2 -light -fast -super 2 -filter "%1.map"

After running the command, I get no errors and a bsp file is created.  The file is created in the OpenArena/baseoa/maps directory. 

I start Open Arena, join a single player game and run the following commands at the OA commandline.

/sv_pure 0
/devmap MyTest
Can't find map maps/MyTest.bsp

I zipped up the maps directory and deleted everything except the MyTest.bsp and renamed the zip file MyTest.pk3 and dropped it in the baseoa directory, but still found nothing. (not sure how I'm actually supposed to pak a pk3 file)

Sorry, trying to provide as much information as I possibly can.

Makes me wish I had strace on Windows. :/

EDIT: switched to all lowercase letters because of a howto I just read. (mytest1.map)  Didnt' help.  Still can't find the map (bsp)
« Last Edit: November 29, 2007, 01:10:57 PM by Dave » Logged
Dave
Nub


Cakes 0
Posts: 29


« Reply #5 on: November 29, 2007, 02:43:41 PM »

Ok, I thought I had tried this before (as noted in the last post)

I zip the maps directory up and name it <my_map_name>.pk3 and I'm able to load it now.

More issues with lighting and stuff, but I will try and figure that out on my own first.

Thanks for all the help offered.
Logged
Pages: [1]
  Print  
 
Jump to: