Pages: [1] 2
  Print  
Author Topic: Yet another Opengl problem!! :(  (Read 19438 times)
kikeonline
Nub


Cakes 0
Posts: 16


« on: June 10, 2008, 01:49:40 PM »

Ok firts of all:

1) I install my latest  Intel Corporation 82845G/GL Drivers
2) I could play Openarena some days before, I dont know what happened!!!!

$ openarea

Code:
ioQ3 1.33+oa linux-i386 Oct 28 2007
----- FS_Startup -----
Current search path:
/home/kike/.openarena/baseoa
/usr/share/games/openarena/baseoa/pak7-patch.pk3 (76 files)
/usr/share/games/openarena/baseoa/pak6-misc.pk3 (191 files)
/usr/share/games/openarena/baseoa/pak5-TA.pk3 (11 files)
/usr/share/games/openarena/baseoa/pak4-textures.pk3 (1496 files)
/usr/share/games/openarena/baseoa/pak3-music.pk3 (9 files)
/usr/share/games/openarena/baseoa/pak2-players.pk3 (620 files)
/usr/share/games/openarena/baseoa/pak2-players-mature.pk3 (171 files)
/usr/share/games/openarena/baseoa/pak1-maps.pk3 (73 files)
/usr/share/games/openarena/baseoa/pak0.pk3 (926 files)
/usr/share/games/openarena/baseoa
/usr/lib/games/openarena/baseoa

----------------------
3573 files in pk3 files
execing default.cfg
execing q3config.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
----- Client Initialization -----
Couldn't read q3history.
----- Initializing Renderer ----
-------------------------------
QKEY found.
----- Client Initialization Complete -----
----- R_Init -----

------- Input Initialization -------
Joystick is not active.
------------------------------------
...loading libGL.so.1:
Calling SDL_Init(SDL_INIT_VIDEO)...
SDL_Init(SDL_INIT_VIDEO) passed.
QGL_Init: Can't load libGL.so.1 from /etc/ld.so.conf or current dir: No dynamic GL support in video driver
failed
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
Sys_Error: GLimp_Init() - could not load OpenGL subsystem


$  openarena +r_allowSoftwareGL 1


Code:
ioQ3 1.33+oa linux-i386 Oct 28 2007
----- FS_Startup -----
Current search path:
/home/kike/.openarena/baseoa
/usr/share/games/openarena/baseoa/pak7-patch.pk3 (76 files)
/usr/share/games/openarena/baseoa/pak6-misc.pk3 (191 files)
/usr/share/games/openarena/baseoa/pak5-TA.pk3 (11 files)
/usr/share/games/openarena/baseoa/pak4-textures.pk3 (1496 files)
/usr/share/games/openarena/baseoa/pak3-music.pk3 (9 files)
/usr/share/games/openarena/baseoa/pak2-players.pk3 (620 files)
/usr/share/games/openarena/baseoa/pak2-players-mature.pk3 (171 files)
/usr/share/games/openarena/baseoa/pak1-maps.pk3 (73 files)
/usr/share/games/openarena/baseoa/pak0.pk3 (926 files)
/usr/share/games/openarena/baseoa
/usr/lib/games/openarena/baseoa

----------------------
3573 files in pk3 files
execing default.cfg
execing q3config.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
----- Client Initialization -----
Couldn't read q3history.
----- Initializing Renderer ----
-------------------------------
QKEY found.
----- Client Initialization Complete -----
----- R_Init -----

------- Input Initialization -------
Joystick is not active.
------------------------------------
...loading libGL.so.1:
Calling SDL_Init(SDL_INIT_VIDEO)...
SDL_Init(SDL_INIT_VIDEO) passed.
QGL_Init: Can't load libGL.so.1 from /etc/ld.so.conf or current dir: No dynamic GL support in video driver
failed
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
Sys_Error: GLimp_Init() - could not load OpenGL subsystem

$ ./openarena +set r_allowSoftwareGL 1 +set r_mode 0 +set r_lodbias 4 +set r_textureMode GL_NEAREST_MIPMAP_NEAREST +set r_picmip 2 +set r_vertexLight 1

Code:
ioQ3 1.33+oa linux-i386 Oct 28 2007
----- FS_Startup -----
Current search path:
/home/kike/.openarena/baseoa
/usr/share/games/openarena/baseoa/pak7-patch.pk3 (76 files)
/usr/share/games/openarena/baseoa/pak6-misc.pk3 (191 files)
/usr/share/games/openarena/baseoa/pak5-TA.pk3 (11 files)
/usr/share/games/openarena/baseoa/pak4-textures.pk3 (1496 files)
/usr/share/games/openarena/baseoa/pak3-music.pk3 (9 files)
/usr/share/games/openarena/baseoa/pak2-players.pk3 (620 files)
/usr/share/games/openarena/baseoa/pak2-players-mature.pk3 (171 files)
/usr/share/games/openarena/baseoa/pak1-maps.pk3 (73 files)
/usr/share/games/openarena/baseoa/pak0.pk3 (926 files)
/usr/share/games/openarena/baseoa
/usr/lib/games/openarena/baseoa

----------------------
3573 files in pk3 files
execing default.cfg
execing q3config.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
----- Client Initialization -----
Couldn't read q3history.
----- Initializing Renderer ----
-------------------------------
QKEY found.
----- Client Initialization Complete -----
----- R_Init -----

------- Input Initialization -------
Joystick is not active.
------------------------------------
...loading libGL.so.1:
Calling SDL_Init(SDL_INIT_VIDEO)...
SDL_Init(SDL_INIT_VIDEO) passed.
QGL_Init: Can't load libGL.so.1 from /etc/ld.so.conf or current dir: No dynamic GL support in video driver
failed
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
Sys_Error: GLimp_Init() - could not load OpenGL subsystem


No matter what I try I get the same error Sad the wierd part is that I could run openarena perfectly last week!!!!!

PLEASE HELP!!!!!!!!!
Logged
kikeonline
Nub


Cakes 0
Posts: 16


« Reply #1 on: June 10, 2008, 02:04:21 PM »

Just to let you know I installl 6.0 windows version under wine and works perfectly!!! but I want to play linux version Sad
Logged
CFQ
---
Member


Cakes 0
Posts: 173


---


« Reply #2 on: June 10, 2008, 03:19:23 PM »

----
« Last Edit: August 13, 2008, 08:09:11 PM by CFQ » Logged

I blanked my posts because I don't like this forum anymore! BAWWWWW
kikeonline
Nub


Cakes 0
Posts: 16


« Reply #3 on: June 10, 2008, 04:38:01 PM »

Is is there... I saw libGL.so , libGL.son.1 and libGL.so.1.2

I dont know what you meen by symlink Sad
Logged
CFQ
---
Member


Cakes 0
Posts: 173


---


« Reply #4 on: June 10, 2008, 07:24:35 PM »

----
« Last Edit: August 13, 2008, 08:09:28 PM by CFQ » Logged

I blanked my posts because I don't like this forum anymore! BAWWWWW
kikeonline
Nub


Cakes 0
Posts: 16


« Reply #5 on: June 10, 2008, 07:40:42 PM »

OH Sorry that was a typo mistake!!

-------------------------------------------------------------

I cant run any opengl application, I tried Tremulous and Wings3d and I get the same error.

ok in /xorg/modules/extensions I see a file libglx.so so I have to rename that file?

I'm sorry but i'm a linux noob. learning everyday from all the forums.

Thanks a lot for you help!

So what do I do?
Logged
CFQ
---
Member


Cakes 0
Posts: 173


---


« Reply #6 on: June 11, 2008, 05:15:04 AM »

----

« Last Edit: August 13, 2008, 08:09:47 PM by CFQ » Logged

I blanked my posts because I don't like this forum anymore! BAWWWWW
kikeonline
Nub


Cakes 0
Posts: 16


« Reply #7 on: June 11, 2008, 02:13:18 PM »

I'm using ubuntu.

ok theres no other file named libGLx.<some_number>.so

when I create the symlink what number do i have to put in <some_number>
Logged
CFQ
---
Member


Cakes 0
Posts: 173


---


« Reply #8 on: June 11, 2008, 02:26:52 PM »

----
« Last Edit: August 13, 2008, 08:10:10 PM by CFQ » Logged

I blanked my posts because I don't like this forum anymore! BAWWWWW
kikeonline
Nub


Cakes 0
Posts: 16


« Reply #9 on: June 11, 2008, 02:36:33 PM »

Code:
total 2648
drwxr-xr-x 2 root root    4096 2008-06-11 16:16 .
drwxr-xr-x 8 root root    4096 2008-04-22 13:52 ..
-rw-r--r-- 1 root root   18824 2008-04-15 13:41 libdbe.so
-rw-r--r-- 1 root root   40629 2008-04-15 13:41 libdri.so
-rw-r--r-- 1 root root  151354 2008-04-15 13:41 libextmod.so
-rw-r--r-- 1 root root 2409784 2008-04-15 13:41 libGLcore.so
lrwxrwxrwx 1 root root      10 2008-06-11 16:11 libglx.bak -> libGL.so.1
lrwxrwxrwx 1 root root      11 2008-06-11 16:16 libglx.so -> libGLx.1.so
-rw-r--r-- 1 root root   27976 2008-04-15 13:41 librecord.so
-rw-r--r-- 1 root root   39783 2008-04-15 13:41 libxtrap.so

I made those symlinks Sad just trying.
Logged
CFQ
---
Member


Cakes 0
Posts: 173


---


« Reply #10 on: June 11, 2008, 03:10:47 PM »

----
« Last Edit: August 13, 2008, 08:10:34 PM by CFQ » Logged

I blanked my posts because I don't like this forum anymore! BAWWWWW
kikeonline
Nub


Cakes 0
Posts: 16


« Reply #11 on: June 11, 2008, 03:22:42 PM »

I reinstall the xserver-xorg-core , hope that didnt make the problem bigger


this is what i get:

Code:
name of display: :0.0
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x21 24 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x22 24 dc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x49 32 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Logged
CFQ
---
Member


Cakes 0
Posts: 173


---


« Reply #12 on: June 11, 2008, 04:31:26 PM »

-----
« Last Edit: August 13, 2008, 08:10:55 PM by CFQ » Logged

I blanked my posts because I don't like this forum anymore! BAWWWWW
kikeonline
Nub


Cakes 0
Posts: 16


« Reply #13 on: June 11, 2008, 04:40:51 PM »

Well I install "latest" driver from the intel support website, but I did that hoping that it was going to resolve the problem.

but after the problem all my opengl programs work fine with ubuntu out of the box.

I always accept all the updates too... i have ubuntu 8.02

is there any way I can rollback the video drivers? or see the installed drivers history?
« Last Edit: June 11, 2008, 04:42:27 PM by kikeonline » Logged
CFQ
---
Member


Cakes 0
Posts: 173


---


« Reply #14 on: June 11, 2008, 04:47:46 PM »

----
« Last Edit: August 13, 2008, 08:11:11 PM by CFQ » Logged

I blanked my posts because I don't like this forum anymore! BAWWWWW
kikeonline
Nub


Cakes 0
Posts: 16


« Reply #15 on: June 11, 2008, 05:12:14 PM »

I followed this instruccion http://www.intellinuxgraphics.org/download.html

But why the game worked a while ago and now doesn't work??? can an update mess it up?
Logged
CFQ
---
Member


Cakes 0
Posts: 173


---


« Reply #16 on: June 11, 2008, 06:13:50 PM »

----
« Last Edit: August 13, 2008, 08:11:29 PM by CFQ » Logged

I blanked my posts because I don't like this forum anymore! BAWWWWW
CFQ
---
Member


Cakes 0
Posts: 173


---


« Reply #17 on: June 11, 2008, 06:16:28 PM »

----
« Last Edit: August 13, 2008, 08:11:47 PM by CFQ » Logged

I blanked my posts because I don't like this forum anymore! BAWWWWW
kikeonline
Nub


Cakes 0
Posts: 16


« Reply #18 on: June 11, 2008, 06:27:50 PM »

I'm so confuse :s

 I just put those commands in the terminal and it downloaded something I dont know if they are complie or not lol.

The old driver had absolutely nothing wrong, but all of a sudden opengl programs stopped working.... and since the firts thing to do when an opengl problem ocures is to install lates drivers then I THINK I install new drivers :S

« Last Edit: June 11, 2008, 06:31:16 PM by kikeonline » Logged
CFQ
---
Member


Cakes 0
Posts: 173


---


« Reply #19 on: June 11, 2008, 07:32:49 PM »

----
« Last Edit: August 13, 2008, 08:12:05 PM by CFQ » Logged

I blanked my posts because I don't like this forum anymore! BAWWWWW
fufinha
stop making alt accounts and self-termination
Member


Cakes 7
Posts: 584


retired


« Reply #20 on: June 12, 2008, 05:24:32 AM »

Why you playing with this? +r_allowSoftwareGL 1

You would normally want the system to control the own GL?
Logged
CFQ
---
Member


Cakes 0
Posts: 173


---


« Reply #21 on: June 12, 2008, 07:50:10 AM »

----
« Last Edit: August 13, 2008, 08:12:23 PM by CFQ » Logged

I blanked my posts because I don't like this forum anymore! BAWWWWW
kikeonline
Nub


Cakes 0
Posts: 16


« Reply #22 on: June 12, 2008, 08:00:54 AM »

@CFQ
I reinstall libgl1-mesa-dri & libgl1-mesa-glx  .... Nothing solved Sad

Everybody tells me that those commands should work Sad not for me ...

CFQ REMEMBER YOU TOLD ME TO GLXINFO AND POST WHAT! I GET SOMETHING DIFERENTE NOW. CHECK IT OUT:

Code:
kike@ronald:~$ glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer,
    GLX_OML_swap_method, GLX_SGI_make_current_read, GLX_SGI_swap_control,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
    GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_OML_sync_control,
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
    GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap
GLX version: 1.2
GLX extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
    GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_SGI_make_current_read,
    GLX_SGI_swap_control, GLX_SGI_video_sync, GLX_SGIS_multisample,
    GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) 845G 20061017 x86/MMX/SSE2
OpenGL version string: 1.3 Mesa 7.0.3
OpenGL extensions:
    GL_ARB_imaging, GL_ARB_multisample, GL_ARB_multitexture,
    GL_ARB_point_parameters, GL_ARB_texture_border_clamp,
    GL_ARB_texture_compression, GL_ARB_texture_cube_map,
    GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
    GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3,
    GL_ARB_texture_mirrored_repeat, GL_ARB_texture_rectangle,
    GL_ARB_transpose_matrix, GL_ARB_vertex_buffer_object,
    GL_ARB_vertex_program, GL_ARB_window_pos, GL_EXT_abgr, GL_EXT_bgra,
    GL_EXT_blend_color, GL_EXT_blend_equation_separate,
    GL_EXT_blend_func_separate, GL_EXT_blend_minmax, GL_EXT_blend_subtract,
    GL_EXT_clip_volume_hint, GL_EXT_cull_vertex, GL_EXT_compiled_vertex_array,
    GL_EXT_convolution, GL_EXT_copy_texture, GL_EXT_draw_range_elements,
    GL_EXT_fog_coord, GL_EXT_histogram, GL_EXT_multi_draw_arrays,
    GL_EXT_packed_pixels, GL_EXT_point_parameters, GL_EXT_polygon_offset,
    GL_EXT_rescale_normal, GL_EXT_secondary_color,
    GL_EXT_separate_specular_color, GL_EXT_stencil_wrap, GL_EXT_subtexture,
    GL_EXT_texture, GL_EXT_texture3D, GL_EXT_texture_edge_clamp,
    GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
    GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic,
    GL_EXT_texture_lod_bias, GL_EXT_texture_object, GL_EXT_texture_rectangle,
    GL_EXT_vertex_array, GL_3DFX_texture_compression_FXT1,
    GL_APPLE_client_storage, GL_APPLE_packed_pixels,
    GL_ATI_blend_equation_separate, GL_IBM_rasterpos_clip,
    GL_IBM_texture_mirrored_repeat, GL_INGR_blend_func_separate,
    GL_MESA_pack_invert, GL_MESA_ycbcr_texture, GL_MESA_window_pos,
    GL_NV_blend_square, GL_NV_light_max_exponent, GL_NV_texture_rectangle,
    GL_NV_texgen_reflection, GL_NV_vertex_program, GL_NV_vertex_program1_1,
    GL_OES_read_format, GL_SGI_color_matrix, GL_SGI_color_table,
    GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp,
    GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SUN_multi_draw_arrays

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 24 tc  0 32  0 r  y  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
0x24 24 tc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
0x25 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x26 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x27 24 tc  0 32  0 r  y  .  8  8  8  8  0  0  0 16 16 16 16  0 0 Slow
0x28 24 tc  0 32  0 r  .  .  8  8  8  8  0  0  0 16 16 16 16  0 0 Slow
0x29 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x2a 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x2b 24 dc  0 32  0 r  y  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
0x2c 24 dc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
0x2d 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x2e 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x2f 24 dc  0 32  0 r  y  .  8  8  8  8  0  0  0 16 16 16 16  0 0 Slow
0x30 24 dc  0 32  0 r  .  .  8  8  8  8  0  0  0 16 16 16 16  0 0 Slow
0x31 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x32 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x59 32 tc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 Ncon

Openarena Windows Version works perfectly under Wine , but it doesn't recognize the keyboard.
« Last Edit: June 12, 2008, 08:06:13 AM by kikeonline » Logged
CFQ
---
Member


Cakes 0
Posts: 173


---


« Reply #23 on: June 12, 2008, 08:17:58 AM »

----
« Last Edit: August 13, 2008, 08:13:00 PM by CFQ » Logged

I blanked my posts because I don't like this forum anymore! BAWWWWW
kikeonline
Nub


Cakes 0
Posts: 16


« Reply #24 on: June 12, 2008, 08:43:49 AM »

So it should work??? but I get the same error Sad

When I open Openarena in Wine I can't use the keyboard only the mouse.
Logged
Pages: [1] 2
  Print  
 
Jump to: