Pages: [1] 2
  Print  
Author Topic: OpenArena too dark  (Read 77461 times)
poldie
Nub


Cakes 0
Posts: 32


« on: May 07, 2010, 04:48:29 PM »

Since installing Ubuntu 10.04 (64 bit) the game is too dark.  The brightness control does nothing.  I've googled, and found people suggesting r_overbrightbits 0 which makes a small change, but it's still too dark - far darker than before.   QuakeLive works fine, as does everything non-3d, so the problem is just with OpenArena.  Can anyone recommend some more console commands I can try.  I'm not desperate to download tools, make config files to my system but I guess I could give it a go if there's no alternative.
Logged
HelloKitty!
Lesser Nub


Cakes 12
Posts: 115



« Reply #1 on: May 08, 2010, 03:06:59 PM »

AFAIR, there is a Mesa bug causing this.

No idea how to fix it ATM.
Logged
zigguruat
Nub


Cakes 1
Posts: 15


« Reply #2 on: May 09, 2010, 12:31:12 PM »

im having the same issue with it being too dark except im running win 7.
Logged

War doesn't decide who is right...only who is left
...
Half-Nub


Cakes 10
Posts: 75

Also known as Dots & cookies


WWW
« Reply #3 on: May 09, 2010, 06:28:18 PM »

im having the same issue with it being too dark except im running win 7.

I recently installed Windows 7 on a netbook (yes i know a netbook). And ran OA and noticed it was dark as well.

Changing the gamma solved that.

/r_gamma 1.3

Thats what i used (default is 1). I recommend you both try making your gamma slightly higher and see if that helps.
Logged
RMF
Member


Cakes 12
Posts: 694



« Reply #4 on: May 10, 2010, 01:36:38 AM »

iirc r_gamma is the same as the brightness in the setup
The brightness control does nothing.
Logged
MIOW
Lesser Nub


Cakes 5
Posts: 141


I play to win.


« Reply #5 on: May 10, 2010, 11:59:03 AM »

You can experiment with r_mapOverBrightBits, r_overBrightBits, r_intensity and r_gamma.
Logged
sago007
Posts a lot
*

Cakes 62
Posts: 1664


Open Arena Developer


WWW
« Reply #6 on: May 10, 2010, 12:34:22 PM »

if r_ignorehwgamma is 1 then r_gamma will be ignored and the game will stay dark. Unfortunately it sounds like some drivers in Ubuntu 10.04 ignores the gamma setting provided by OA. I don't have any problems though all my problems with 9.10 disappeared with 10.04.
Logged

There are nothing offending in my posts.
Falkland
Member


Cakes 6
Posts: 590


« Reply #7 on: May 11, 2010, 08:16:17 AM »

I can confirm this bug too on my old laptop after upgrading form Hardy to Lucid Lynx ( ATI Mobility Radeon 9200 , opensource driver ) and not only for openarena but for every engine based on ioquake3 ( tested on ioquake3+Q3 , OA , UrT - ioquake3 rev 1783 ). The driver simply ignores the game gamma settings : increasing r_gamma doesn't have any effect.

Performances are also affected ( it seems coming back to the original Hardy performances with max 66-67 fps ) also with a kernel recompiled for improving interactivity ( LOW-Latency-Desktop-Preemption , 1000Hz , 4k stack , -march=pentium-m ).

Logged
zigguruat
Nub


Cakes 1
Posts: 15


« Reply #8 on: May 11, 2010, 02:43:38 PM »

You can experiment with r_mapOverBrightBits, r_overBrightBits, r_intensity and r_gamma.

r_overbrightbits 1 (either 1 or 0) fixed it for me punched
Logged

War doesn't decide who is right...only who is left
poldie
Nub


Cakes 0
Posts: 32


« Reply #9 on: May 13, 2010, 04:13:49 PM »

You can experiment with r_mapOverBrightBits, r_overBrightBits, r_intensity and r_gamma.

r_overbrightbits 1 (either 1 or 0) fixed it for me punched

none of this advice seems to make any difference - in fact it's now darker.  r_gamma is yet to do anything, the brightness control still does nothing, ignorehwgamma only says anything when I set it to 1, not 0, but does nothing. I think the only thing which makes a difference is r_overbrightbits which changes the brightness a tiny bit. 
Logged
fromhell
Administrator
GET A LIFE!
**********

Cakes 35
Posts: 14519



WWW
« Reply #10 on: May 13, 2010, 04:21:04 PM »

Try disabling compositing
Logged

asking when OA3 will be done won't get OA3 done.
Progress of OA3 currently occurs behind closed doors alone

I do not provide technical support either.

new code development on github
Falkland
Member


Cakes 6
Posts: 590


« Reply #11 on: May 13, 2010, 05:49:54 PM »

Try disabling compositing

r_gamma is ignored even with compositing disabled.
Logged
MIOW
Lesser Nub


Cakes 5
Posts: 141


I play to win.


« Reply #12 on: May 13, 2010, 05:55:41 PM »

none of this advice seems to make any difference - in fact it's now darker.  r_gamma is yet to do anything, the brightness control still does nothing, ignorehwgamma only says anything when I set it to 1, not 0, but does nothing. I think the only thing which makes a difference is r_overbrightbits which changes the brightness a tiny bit.  

Sorry, I never had this problem actually :/

But be sure with those cvars you can make game look brighter, depends on what you put there. I just didn't bother to find values myself since I don't know how would it look on your or somebody else's monitor, who has this problem. btw do you know of vid_restart?

Otherwise if it really ignores all of those settings somehow, it's really incredible.
Logged
PopeJo
Lesser Nub


Cakes 12
Posts: 105



WWW
« Reply #13 on: May 15, 2010, 02:55:32 AM »

I have that problem with ioquake3 (and the defrag engine)
 r_gamma and r_ignorehwgamma have no effekt, only r_mapoverbrightbits works

gamma control works in openarena for me, but I got sound problems in return http://openarena.ws/board/index.php?topic=3458.msg31754#msg31754
Logged

poldie
Nub


Cakes 0
Posts: 32


« Reply #14 on: May 17, 2010, 03:38:31 PM »

I have that problem with ioquake3 (and the defrag engine)
 r_gamma and r_ignorehwgamma have no effekt, only r_mapoverbrightbits works

gamma control works in openarena for me, but I got sound problems in return http://openarena.ws/board/index.php?topic=3458.msg31754#msg31754

I don't to sound lazy or anything, but I just can't play OpenArena any more - it's too dark, and none of the suggestions have made any difference.  If I can't use the brightness slider, that's a bug somewhere, right?  I've tried this and that console command, without really knowing what I'm doing, and as far as I can see it's made no difference whatsoever. 
Logged
Cacatoes
Banned for leasing own account
Posts a lot
*

Cakes 73
Posts: 1427


also banned for baiting another to violate rules


« Reply #15 on: May 17, 2010, 04:32:41 PM »

What's your graphic card ? If it's a driver issue, you may try some other versions (a mess to do), or give a try to some other distribution as a test.
Logged

Todo: Walk the cat.
Falkland
Member


Cakes 6
Posts: 590


« Reply #16 on: May 17, 2010, 05:23:06 PM »

What's your graphic card ? If it's a driver issue, you may try some other versions (a mess to do), or give a try to some other distribution as a test.

There's an experimental PPA repository for trying updated drm and xorg drivers : https://launchpad.net/~xorg-edgers/+archive/ppa , but since they are built from git snapshot they could be unstable.

I've used this archives to solve ATI performance issues after upgrading from Gutsy to Hardy , but I didn't tried 'em in Lucid yet, since I'm trying first to build a patched kernel with an updated drm ATI driver coming from mainline ( the latest kernel version was released just yesterday - 2.6.34 - ) which has introduced some improvements to radeon driver http://kernelnewbies.org/Linux_2_6_34#head-401677e9a1218ca685bc95bcb1891f0c61b912f9 ( in particular this commit )

Anyway an updated kernel version is also available in the same xorg-edgers repository.

It was also published a guide on ubuntu forums to install and/or to build a low latency kernel or a realtime kernel ( http://ubuntuforums.org/showthread.php?t=1470264 )

However , don't try any of this solutions if you are not experienced with mixing repos or kernel compiling or recovering procedures when something goes wrong.

EDIT : this time PPA uploaders provided ppa-purge command that automaticily reverts updated packages back to the default coming with distribution and deletes the PPA sources from /etc/apt/sources.list
« Last Edit: May 19, 2010, 09:51:32 AM by Falkland » Logged
Gig
In the year 3000
***

Cakes 45
Posts: 4384


WWW
« Reply #17 on: May 18, 2010, 10:14:15 AM »

Did you already try to rename your q3config.cfg file in DO NOT LINK[/b]) h t t p s : / / openarena . wikia . com/wiki/FAQ#Where_are_the_configuration_files_saved.3F]your configuration folder, to start again with a "clean" one?
Logged

I never want to be aggressive, offensive or ironic with my posts. If you find something offending in my posts, read them again searching for a different mood there. If you still see something bad with them, please ask me infos. I can be wrong at times, but I never want to upset anyone.
Falkland
Member


Cakes 6
Posts: 590


« Reply #18 on: May 19, 2010, 09:06:52 AM »

It's not a config issue ... it's a bug of the MESA GLX driver : r_gamma is ignored in every ioquake3 based game ( Q3+ioq3 , UrT , OA , Smokin' Guns , q3min )
Logged
Falkland
Member


Cakes 6
Posts: 590


« Reply #19 on: May 25, 2010, 06:09:29 AM »

The culprit for this BUG is a Xorg change introduced in the version 7.5 as reported in the libsdl buglist :

Gamma control do not work with Xorg 7.5 release

It seems that an eventual SDL update will not solve completely the problem , breaking the gamma control for other games.

Anyway as a workaround , gamma should be changed with xgamma tool before launching the game and restored after quitting it.
Logged
xnonix
Nub


Cakes 0
Posts: 27


« Reply #20 on: December 21, 2010, 06:06:39 AM »

Well, if you want to set gamma in ubuntu you must do this way.

Open a terminal in ubuntu:
Code:
xgamma -gamma 1.6


This change your gamma to 1.6, this will affect OA if you open it in window mode.
Put back to 1.0 after your OA session.

Regards
« Last Edit: December 21, 2010, 06:18:01 AM by xnonix » Logged
PopeJo
Lesser Nub


Cakes 12
Posts: 105



WWW
« Reply #21 on: February 08, 2011, 05:29:26 PM »

The culprit for this BUG is a Xorg change introduced in the version 7.5 as reported in the libsdl buglist :

Gamma control do not work with Xorg 7.5 release

It seems that an eventual SDL update will not solve completely the problem , breaking the gamma control for other games.

Anyway as a workaround , gamma should be changed with xgamma tool before launching the game and restored after quitting it.
so .. is this problem resolved in maverik?

or is there another solution besides the "xgamma-way", that I am using for the last few month?
Logged

WingedPanther
Member


Cakes 4
Posts: 190



« Reply #22 on: February 10, 2011, 06:52:05 PM »

I'm on 10.10 right now.  It's not fixed Sad

I've got a couple of bash scripts on my desktop to set up to handle that.  One of them also logs me on/off of Hamachi.
Logged

Programming is a branch of mathematics.
Udi
Member


Cakes 25
Posts: 536


i do my own stunts


WWW
« Reply #23 on: February 11, 2011, 04:22:48 AM »

I'm on 10.10 right now.  It's not fixed Sad

Works for me: Ubuntu 10.10, xorg: 1:7.5+6ubuntu3, nvidia-current: 260.19.06-0ubuntu1. I actually never had problem with it, neither on Debian (Etch, Lenny) nor Ubuntu (10.04, 10.10), I'm using the unified installer from the website, if that matters.
Logged

http://udionline.hu/en/projektek/openarena/
Todo list: 1. q3dm17 textures replacement (95% done)
WingedPanther
Member


Cakes 4
Posts: 190



« Reply #24 on: February 12, 2011, 09:46:11 AM »

Ah, I'm on intel graphics, but same version of xorg.  I'm using the OA package via synaptic: 0.8.5-4
Logged

Programming is a branch of mathematics.
Pages: [1] 2
  Print  
 
Jump to: