Pages: [1]
  Print  
Author Topic: Solved: Radiant 1.5.0 runtime error  (Read 7852 times)
w1zrd
Member


Cakes 2
Posts: 582


Give to life what you expect back


WWW
« on: July 19, 2007, 03:27:12 AM »

I get strange errors when launching the 1.5 version under what is now kubuntu 7.0.4 this time around, so here is what it looks like:

in /usr/local/games/gtkradiant-1.5.0/games/oa.game entry is as follows:

<?xml version="1.0"?>
<game
  type="q3"
  index="1"
  name="Open Arena"
  enginepath_win32="C:/Program Files/Quake III Arena/"
  enginepath_linux="/home/username/openarena-0.7.0/"
  enginepath_macos="/Applications/Quake3/"
  engine_win32="quake3.exe"
  engine_linux="ioquake3.i386"
  engine_macos="Quake3.app"
  prefix=".openarena"
  basegame="baseoa"
  basegamename="Open Arena"
  knowngame="missionpack"
  knowngamename="Open Arena"
  unknowngamename="Custom Open Arena modification"
  shaderpath="scripts"
  archivetypes="pk3"
  texturetypes="tga jpg"
  modeltypes="md3 ase lwo obj 3ds picoterrain"
  maptypes="mapq3"
  shaders="quake3"
  entityclass="quake3"
  entityclasstype="xml"
  entities="quake3"
  brushtypes="quake3"
  patchtypes="quake3"
/>

and in /usr/local/games/gtkradiant-1.5.0/oa.game/baseoa is the default_shaderlist.txt as it would be (copied from q3).

In the shell I get:

username@host:~$ radiant
X Error: BadDevice, invalid or uninitialized input device 169
  Major opcode:  145
  Minor opcode:  3
  Resource id:  0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 169
  Major opcode:  145
  Minor opcode:  3
  Resource id:  0x0
Failed to open device

(i.e not trying as root due to security issues)

gtk starts relatively fine, with exception from the:
Unable to find default tag file /usr/local/games/gtkradiant-1.5.0/oa.game/shadertags.xml. No tag support.
(which dmn_clown said to ignore)

and also this following error (see screenshot):

Strangely however, it seems to work (start) but would it have consequences during builds?
« Last Edit: November 30, 2007, 12:55:44 PM by w1zrd » Logged

'Toto, I've a feeling we're not in Kansas anymore.'


dmn_clown
Posts a lot
*

Cakes 1
Posts: 1324


« Reply #1 on: July 19, 2007, 08:20:00 AM »

The default build menu seems to be missing which is the cause for your error gif.

Oh yeah, applying this patch:  http://openarena.ws/board/index.php?topic=549.msg3438#msg3438 to q3map2 and rebuilding will provide you with full oa map compiling support, though the build menu will need to be edited accordingly. 
Logged

w1zrd
Member


Cakes 2
Posts: 582


Give to life what you expect back


WWW
« Reply #2 on: November 26, 2007, 07:54:41 AM »

Bumping this one rather than spreading it out..
After a recent HDD crash I now compiled GTK Radiant from SVN, this time around there were no runtime errors at startup but at map-compile then I get an error that looks like:
Code:
=== running build command ===
"/home/USERNAME/games/SVN/GtkRadiant/install/q3map2.x86" -v -connect 127.0.0.1:39000 -game quake3 -fs_basepath "/home/USERNAME/games/openarena-0.7.0/" -fs_game baseoa -vis -fast "/home/USERNAME/.openarena/baseoa/maps/test.map"
Connected.
threads: 4
Q3Map         - v1.0r (c) 1999 Id Software Inc.
Q3Map (ydnar) - v2.5.17
GtkRadiant    - v1.5.0 Nov 25 2007 06:27:40
Last one turns the lights off
--- InitPaths ---
VFS Init: /home/USERNAME/.q3a/baseoa/
VFS Init: /home/USERNAME/games/openarena-0.7.0//baseoa/
VFS Init: /home/USERNAME/.q3a/baseq3/
VFS Init: /home/USERNAME/games/openarena-0.7.0//baseq3/

--- Vis ---
fastvis = true
Loading /home/USERNAME/.openarena/baseoa/maps/test.bsp
************ ERROR ************
Error opening /home/USERNAME/.openarena/baseoa/maps/test.bsp: No such file or directory
Received error msg .. shutting down..
I have no idea where the double trailing slashes are coming from, nor can I find a way around it. Ideas anyone?
Logged

'Toto, I've a feeling we're not in Kansas anymore.'


dmn_clown
Posts a lot
*

Cakes 1
Posts: 1324


« Reply #3 on: November 26, 2007, 12:32:48 PM »

apply this patch to q3map2 (q3map2 doesn't really support oa properly without it): http://openarena.ws/svn/tools/radiant1_5/q3map2/oamap.diff

Code:
mv oamap.diff ~/games/SVN/GtkRadiant/
cd ~/games/SVN/GtkRadiant
patch -p0 < oamap.diff
scons

then try again.
Logged

w1zrd
Member


Cakes 2
Posts: 582


Give to life what you expect back


WWW
« Reply #4 on: November 26, 2007, 05:24:46 PM »

apply this patch to q3map2 (q3map2 doesn't really support oa properly without it): http://openarena.ws/svn/tools/radiant1_5/q3map2/oamap.diff

Code:
mv oamap.diff ~/games/SVN/GtkRadiant/
cd ~/games/SVN/GtkRadiant
patch -p0 < oamap.diff
scons

then try again.
Hmm, I did apply that one as per your previous advice but still it fails to build maps.
I still do get that shader
Code:
Unable to find default tag file /gtkradiant-1.5.0/oa.game/shadertags.xml. No tag support.
though if that is of any relevance.
Logged

'Toto, I've a feeling we're not in Kansas anymore.'


dmn_clown
Posts a lot
*

Cakes 1
Posts: 1324


« Reply #5 on: November 26, 2007, 06:01:22 PM »

Hmm, I did apply that one as per your previous advice but still it fails to build maps.
I still do get that shader
Code:
Unable to find default tag file /gtkradiant-1.5.0/oa.game/shadertags.xml. No tag support.
though if that is of any relevance.

You can ignore the shader tag warnings, I guess the obvious question is:  Is test.map in ~/.openarena/baseoa/maps/ ?
Logged

w1zrd
Member


Cakes 2
Posts: 582


Give to life what you expect back


WWW
« Reply #6 on: November 27, 2007, 04:50:39 PM »

Hmm, I did apply that one as per your previous advice but still it fails to build maps.
I still do get that shader
Code:
Unable to find default tag file /gtkradiant-1.5.0/oa.game/shadertags.xml. No tag support.
though if that is of any relevance.

You can ignore the shader tag warnings, I guess the obvious question is:  Is test.map in ~/.openarena/baseoa/maps/ ?
yup, the map/s, are there. so I have no idea why it's not working now Sad
Logged

'Toto, I've a feeling we're not in Kansas anymore.'


dmn_clown
Posts a lot
*

Cakes 1
Posts: 1324


« Reply #7 on: November 27, 2007, 05:51:46 PM »

Quote
************ ERROR ************
Error opening /home/USERNAME/.openarena/baseoa/maps/test.bsp: No such file or directory

that suggests that it can't find the test.bsp, is that there?
Logged

w1zrd
Member


Cakes 2
Posts: 582


Give to life what you expect back


WWW
« Reply #8 on: November 30, 2007, 12:55:21 PM »

Quote
************ ERROR ************
Error opening /home/USERNAME/.openarena/baseoa/maps/test.bsp: No such file or directory

that suggests that it can't find the test.bsp, is that there?
Yup, the .bsp and .map's were there but I figured I'd give it a go the complicated way to I re-installed it from SVN again, applied the patch again, and whatca-now - bob is my uncle...

For some peculiar reason it just decided to work, so most likely I did something to screw up the settings previously. Thanks for the patience..
Logged

'Toto, I've a feeling we're not in Kansas anymore.'


Pages: [1]
  Print  
 
Jump to: